2 questions about key editor

hello everyone,

i have a couple of issues with the key editor i’d like to figure out.

1- if i’m working in the key editor and switch focus to the track editor by clicking on a different clip, the clip is displayed in the track editor as it’ should be, but the position of the key editor changes to some arbitrary location. i’d like to make the key editor stay where i put it. how can i do this ? i have my preferences set to where the cursor in the key editor is sync’d with the cursor in the track editor, but that doesn’t stop this from happening. note that i do not move the cursor when i select a different clip, i’m very careful to leave the cursor exactly where it is.

2- i keep getting ‘stuck’ notes when i try to audition them in the key editor. for example, when i click on a note, the note continues to play even after i release the mouse button. the same thing might happen if i change the position of the note by dragging it to a new location. the only thing that stops the note is going into the vst [kontakt, in this case] and pressing the ‘panic’ button [the ‘!’]. the strange thing is that this only seems to happen as i get close to finishing up a score… :imp: is this something that i’ve inadvertently set up, or is this a bug ?

thanks much.


  1. Yes this Cubase Editor behaviour. :-/ You cannot change it.

  2. where is the MIDI track routed to?

they’re all routed to vsti’s, in this case, kontakt instruments. this is happening on just about every track.

Is it the same when you increase the Buffer Size?

aha ! interesting. you mean the audio sample size buffer in kontakt, right ? or do you mean in the asio driver itself ?

so your premise is that kontakt isn’t registering the note-off event because the audio driver is being overtaxed somehow ? i’m not sure, but i think that would be far-fetched. how would the audio sample buffer affect reception of midi events ? [i’m not nit-picking, mind you, just trying to get my head around this… :slight_smile: ]

anyway, i’ll try fiddling with the audio sample buffer size in kontakt and in the asio, and get back w/the results. there is no buffer that i know of for midi events in either kontakt or my fireface 800.

thanks much for your help so far, martin !

greetings, martin !

i tried increasing my buffer size in the asio driver, first doubling it then doubling it again. that added noticeable latency to when i was ‘playing in’ the notes from my keyboard into cubase, but didn’t solve the problem of note-off events not being recognized when i moved notes within the key editor. :frowning:

this thing really has me scratching my head. have you heard of this kind of thing happening before ?


Could you try the Safe Start Mode of Cubase or Trash Cubase Preferences, please?

well, i moved the ‘cubase_64’ folder completely out of my appdir, cubase remade it, and the problem continued – sometimes. but sometimes i could do an entire session without problems. in fact, it’s hard to reproduce the problem systematically.

but may i infer from your questions that you have never experienced this kind of thing with cubase before ? if so, then it may be a problem with my machine or setup, and not with cubase.

I have never experienced exactly this. But time to time, there are some “holding-notes” issues on some (non-specific) machines.