2 Tascam's US2400 together?

Hi,
Anyone knows if I can use 2 Tascams US2400 to control 48 channels at once? I have one that works perfectly (with C9.0.1/W10 x64) and the opportunity to take another one. Thanks

Hi,

Does it use Mackie Control protocol, right? In his case, yes you can. Just Add 3 more Mackie Control Devices in the Remote Controller.

Thanks Martin. I already have 6 ports enabled with only one Tascam. Only hope that when I’ll add the second Tascam, it will create another six ports. Indeed, I use MCU protocol with some +functions I added later

It’s long time ago when I used it. Why do you need 6 MCU Ports? You can try to Add 6 Mackie Devices already now, to see, if you will see the white line on 48 channels.

Tascam by default add 6 midi ports (from his usb compliant driver). After that, I configure 4 of this for his functions (1 to 24 ch faders and transport functions). My doubt is when I’ll connect the second if Cubase will see another 6 midi ports allocated for the second one. In about 2 weeks I hope I’ll have the second unit…

Hi,

Then I would probably recommend to use only 3 MIDI ports, for the fader. I would be a bit afraid to confuse Cubase by using two Transport sections.

Let’s see, trial and error :wink: Thanks a lot

It should work! In Cubase I have 2 Tascam DM3200’s (which the US2400 is based off of) configured giving me 32 physical faders for control surface. Simultaneously I have 2 Frontier Tranzports configured as well as Steinberg’s CC121. That’s a total of 7 Mackie Control Devices configured in Cubase. Everything works every time without conflict so I believe 2 US2400’s should not be an issue provided that you’ve configured them correctly.

HOWEVER, there’s ONE issue that I have to fix every time I upgrade to a new Windows OS (including Windows 10). Windows doesn’t differentiate the USB device name when more than one DM3200 is connected meaning that both DM3200 USB devices have the same name in the Device Manager. Unless you change one of them through the registry, they can’t be configured correctly in Cubase. Cubase instead shows the MIDI ports of one of the units twice. If the US2400 behaves the same way, you will need to follow this procedure (call is something like US2400-2)

http://www.avoiderrors.net/rename-devices-device-manager/

After 3 full days of fiddling with registry, port xml’s, device manager midi port name changes (which returns to the same names and ports) I feel like giving up :frowning: Nothing works. Only if I could change the “Port System Name” inside cubase (not the “show as” name) could be a chance. In Windows Device Manager they have already different names, but Cubase didn’t get the device changed name :frowning:

That’s surprising. Sorry to hear. Like I said I have 2 Tascam DM3200’s in control surface giving me 32 physical channels, a Steinberg CC121 and 2 Frontier Tranzports working just fine. If the device names are changing back then that means you’ve missed something in the procedure and most likely why you’re not getting it to work.

Using 2 Tascam’s on one computer seems to work using Sonar and I’m am pretty sure Cubase is not the cause of your issue.

http://forum.cakewalk.com/Guide-to-running-2-Tascam-US2400-units-together-in-Sonar-m1451719.aspx

Don’t know what to say… I’ve made all the registry hacks to change the Windows device names, but Cubase Midi port setup still shows all the ports as “US-2400”, no matter I do :frowning: Maibe a Windows 10 Bug, or a C9 pro bug?

Victory!! Well, almost… Found a workaround through MIDI-OX and LoopBe30, bit awkward I know :slight_smile: Must now fiddle with settings. At least it looks good :unamused:

Later edit

After 2 weeks of trial and error the final verdict is: YES IT WORKS! And with full functionality and comfort. But it’s not easy at all :unamused: Disregard any registry hack advice or cakewalk advices… all you need is LoopMidi by Tobias Erichsen and Bome’s Midi Translator Pro. And the configuration should look like this:

So yes :slight_smile:

Good news. Detailed instructions would be awesome. I (or you) could post them on the tascamforums.com site as I am sure there are users there that would benefit from your success.

Congratulations! I have ONE US2400 and love it.
Quick question. Mine did not come with a power supply and I found one that is very close. BUT occasionally my faders “fight” me a little bit. Almost like they are slightly sticking. Not enough for me to call it unusable. Do you ever experience that? If the answer is no, then I will search for a new power supply. The original is not made any more. I have the correct voltage but am why by 1 amp on the spec.

I don’t have the original adaptors for neither of 2 Tascams. What are you experiencing are just what is happening on my Yamaha 01V automated faders occasionally (dust on Alps faders I suppose). Very rare on tascams faders behave a little strange, midi errors (or usb) for sure. Don’t know what to say else…

So no instructions on how to get this working?

To be honest, it was a trial and error process only. I can give some detailed instructions, but only depending on the target system, and building step by step. Otherwise, it will take books :slight_smile: I didn’t even remember all the steps, first 2 weeks only fighting with w10 registry and drivers, then with the MCU protocols midi ins and outs, then with virtual midi drivers and finally with Bome’s translator coupled with LoopMidi (for renaming ins and outs for 2nd Tascam). I’m only a poor violinist… so no deep science involved with me :unamused: