3.4 Breaks Midi Playback (sustain ctlr 64 stuck ON)

Hello, I updated to 3.4 and now I am having issues with MIDI playback, where controller 64 gets stuck ON and interferes with subsequent playback of MIDI tracks. In my setup I have midi tracks that route to external midi instruments, which is where I get the problem. (I use internal midi instruments too, like microsonic and microlight, but the problem is not as prevalent with internal instruments.)

I first encountered this problem on a large project, but I have since been able to consistently reproduce the problem with a new, simple project. Unfortunately this issue is effectively blocking me from working, since my projects use midi tracks extensively, with external midi instruments. Once this problem occurs (ctlr 64 gets stuck ON) it is difficult to turn OFF (midi panic is mostly ineffective and stopping/restarting playback has no effect), and all the midi notes pile on top of each other, ruining playback.

To reproduce, I loaded a new project and added a midi track, set to No Instrument. The midi output is set to my Steinberg ur44c port 1, channel 1, with midi thru enabled. I create an audio track to monitor the stereo outputs from my Roland Integra-7, which is listening on midi ch 1. I record enable the midi track and play on my controller keyboard. I can hear the Integra-7 output through the audio track. I record some chords with sustain pedal and in the midi editor window I can see the notes recorded, and as expected, controller 64 events. All normal. I hit playback, and I hear the Integra-7 play back properly with sustain on/off, as you’d expect. However, if I STOP playback in the middle, (apparently while sustain is ON) the sustain will get stuck ON and the notes will ring on (sustain), until the notes decay. If I resume playback, all (or most) notes are still sustained - there is no sustain on/off during subsequent playback. Once this happens, There is no reliable way to turn sustain off again - midi panic only works sometimes. Also, pressing my controller keyboard’s sustain pedal may turn sustain off temporarily, but if I resume playback sustain is still stuck on. (Also once this problem occurs, sustain often sticks on ACROSS other midi tracks, including internal instruments, so not just the original track. Weird!). I can upload a video that shows these steps, but honestly this was very simple/basic for me to reproduce, so hopefully your team can reproduce too.

Btw my DSP use is very low, especially with the new project, so it’s not a resource contention issue. It also happens with other external midi hardware, not just the Integra-7.

Is there some way to revert back to 3.3, so that I can resume my work? I assume it will take some time for your team to reproduce this problem and to release a patch if warranted. I really can’t afford to stop working in the meantime. If it is not possible to revert, do you have any suggestions for workarounds?

Thanks in advance for your help!

Hi @Steven_Case,

Thanks for your message and welcome to the Cubasis forum.

Please give the following steps a try:
(1) Load the “New Project” project template
(2) Close all apps, including Cubasis
(3) Fully shut down the iPad

Does Cubasis works as expected when relaunching the iPad and the app?

If the problem persists, please let me have a short clip, which shows the exact steps to reproduce the problem. Please feel free to upload the clip via Dropbox or similar and share the link via private message.


Hi Lars,
Thanks for the reply! (Especially since I am blocked from recording midi keyboard tracks while sustain is locked ON!)

I am pretty sure that I tried rebooting the iPad, and I was running Cubasis alone while selecting New Project to reproduce the problem. (I described the steps to reproduce in my earlier message.)

That said, I will follow your steps exactly and get back to you asap with the results, and if it’s still not working I’ll upload a video to show the steps so that (hopefully) your team can reproduce the problem.

Hi Lars ,
Thanks again for your response to my midi playback issue, where controller 64 gets stuck On when you stop playback midstream (in the middle of a midi track that is routed to an external instrument - in this case a Roland Integra-7 module).

As you requested, I created a new project using the New Project template, closed all apps including Cubasis, and rebooted the iPad ( from Settings > General). After following these steps, I was able to recreate the problem consistently, as is illustrated in this video clip, which is uploaded and shared in iCloud. (Hopefully you are able to retrieve this file - sorry it is very large ~130 Mb - I didn’t know how to compress it)

In this clip, you can see that no other apps are running, and no plug-ins are loaded. I create a New Project, and two tracks, a midi track with no instrument with midi thru enabled, and an audio track to monitor the stereo outputs of a Roland Integra-7 module.

In the video, you can hear notes playing initially from my controller keyboard, and sustain on/off is working. I record some simple chords with sustain on/off and everything works fine if I play the track thru until the end.

However, if I stop playback halfway (presumably after a sustain ctr64 ON message is sent) then sustain gets stuck ON and additional notes ring on and on. You will note that sustain is not necessarily stuck on for ALL MIDI notes, as you can see in the video. (Weird) Also, the video shows that midi panic only works sometimes to turn sustain OFF, and even when it does work, sustain may still be ON for subsequent notes that are played.

This is a huge problem for me… since I am a keyboard player all of my songs include midi keyboard tracks with sustain. So I cannot really work on existing projects or work on new projects - I am stuck waiting for a fix for this issue. Is there a way to roll back to 3.3 at least temporarily so that I can continue working?

Also, I did not attempt to reproduce this, but once ctr64 gets stuck on for ONE track, it appears to get stuck on for many / all midi tracks that use ctr 64, including for tracks with internal instruments like Microsonic.

I look forward to hearing back from you to help resolve this issue!


One more thing I should mention, once ctr64 gets stuck on (as described above) the sustain pedal on my midi controller seems to have no effect. Because midi thru is enabled, I can hear notes being played (and they are also sustained), but pressing the sustain pedal does not send the ctr64 OFF message as expected. So it’s like ctr64 messages are being filtered, or dropped, in Cubasis.

I’ve uploaded a second video that shows 2 specific scenarios where Cubasis is introducing problems with sustain ctr64 getting stuck ON during playback.

This video builds on the very simple project that I created earlier, but I edited the MIDI sustain events to make ON/OFF events more obvious, so you can see it clearly in the piano roll window. I also slowed the tempo so you can really see where sustain ON/OFF should happen.

Here is a description of the 2 scenarios in the video:

Scenario 1)
Stop playback in the middle of sustained chord

  • All notes across the keyboard are sustained and sustain is stuck on (not good!)

Next step: On controller keyboard, Press sustain pedal on and off

  • This turns Sustain OFF for most notes, but not for some or all notes in the chord! (Strange!)

Next step: Turn MIDI Thru to Off (disabled) and back on again

  • Turns Sustain OFF for all notes, including notes in chord
  • This seems to effectively reset ctr64 to OFF
  • ?!?!?

Scenario 2)
Stop playback after a chord is struck, but before sustain ON messages have been sent

  • Most notes across the keyboard are NOT sustained, but for notes in the chord, sustain is stuck ON
  • VERY STRANGE since ctr64 ON messages have not even been sent yet!

Next step: On controller keyboard, Press sustain pedal on and off

  • Sustain is still OFF for most notes, but not for some or all notes in the chord
    • (Still pretty STRANGE!)

Next step: Turn MIDI Thru to Off (disabled) and back on again

  • Sustain is off for all notes, including notes in chord

Clearly this is some very strange behavior, and this is new behavior introduced with upgrade to 3.4. (All my projects ran fine with MIDI tracks in 3.3).

My project and environment are very simple, so hopefully should be simple to reproduce. It is MIDI controller out > UR44c > Roland Integra-7 with an iPad in the middle.

Again, I appreciate your help in resolving this issue asap, so I can get back to work making music!


Hi @Steven_Case,

Thanks for the additional details, which I’ve shared with the team.

Our engineers are able to reproduce the problem and will evaluate the options to fix the issue.


Hi Lars,
Thanks for the update - I’m relieved to hear that your engineering team are able to reproduce the problem. I hope that you will be able to push out a fix quickly, since this problem compromises midi playback and restricts efficient midi editing. (The “workaround” that I identified to turn off/on midi thru is not really practical, since you’d have to repeat that every time you stop playback to silence stuck notes.) In the meantime, is there another workaround that you can suggest to bypass the problem? (or a more efficient way to unstick any stuck notes?)


Hi Lars,
Thanks again for confirming your engineering team is able to reproduce the problem. Do you have an update yet on what the solution looks like, or the timing for that solution?

In the meantime, now that your team is (hopefully) gleaning some insights around the root cause, can you offer any workarounds to streamline the MIDI recording/playback workflow? The workarounds I identified above are very tedious and interrupt the creative process as well as mixing-related workflows.

Waiting eagerly for your reply,

Hi @Steven_Case,

Thanks for your message.

Your sustain ctrl 64 issue is planned to be resolved in the update release.
At this moment we do not have a release date to share, but the team is working on the update with high prio.

Best wishes,