3.5: Instant Print Preview on german keyboard?


I really (!) like the instant print preview idea. But on a german keyboard (and I guess other localized keyboard versions will be a problem too), the key next to Z is T. Okay, Z and Y are changed on german keyboards, so it propably is the key next to Y? Nope, that’s < and inserts a beautiful hairpin. Okay, so I take it literally and use the backslash \ (I’m on windows): Alt Gr + ß. Nope. Backtick doesn’t work either. And I can’t find the option in the preferences dialog to assign my own shortcut. :cry:

I desperately hope I am missing something. I would so much like to use this new feature.

Just had a look: the shortcut on German keyboards is Shift + ^ (next to “1”). Works a bit funny: to switch the frames off, you can hit the shortcut once, but to makes them reappear, I have to hold the shortcut a bit longer.

On a German keyboard, for Mac the shortcut is Shift+°. For Windows, it’s Shift+^.

There may indeed be a little problem with it “latching” incorrectly in German, which I wasn’t able to get to the bottom of until yesterday, when Dorico 3.5 had already been built. However, we’ll take care of that in a future update.

Even today taking care of the average customer… Thanks Daniel!
(and HeiPet of course)

Dear Daniel, on my MacBook Pro (latest macOS) with a German keyboard Shift+°doesn’t do anything. Either on a new or all old project. But pressing Cmd+´ hides all the lines. Unfortunately I couldn’t find a way to switch these lines back again. Pressing Cmd+´again doesn’t do anything. All the lines stay invisible…

it works perfectly for me (including the latch).

Do you use the german localization of Dorico? How did you set your Keyboard in the preferences of Dorico?

Hm…My language is set to English, as it much more convenient to follow up all the threads. May I ask you: where do you set your keyboard language separately?

To be clear, it’s not meant to latch, and the latching behaviour will be (has already been) removed. It’s supposed to take effect only as long as you hold the key down.

What I suggest you do is find a convenient single key that requires no modifier to use as the shortcut for this feature.

If I recall correctly (not on my Dorico machine rn), Dorico attempts to take the standard keyboard for you localization, meaning: Dorico is now trying to use your german keyboard layout as if it was an english one. That’s why ` is working for you, rather than ^.
Now here is where I speculate of old memories: you should be able to change the mapping of the keyboard to different layouts in the keyboard shortcut settings.

If you instead set your language to german, the german shortcuts will apply automatically though.
No harm in trying it out and getting back to english, btw :wink:

EDIT: This is why my dorico is also set to german still, although I agree it is easier to follow all the great input with an english version.

You can change which shortcuts you’re using on the Key Commands page of Preferences, where the keyboard language can be set independently from the application UI language.

Thank you Daniel, I set on Key Command page to German language (it was set before to default) and everything works fine now. Thank you for your help😊

By the way the shortcut in German is called “Unsichtbare ausblenden”.
A very strange translation.
I have set “q” as shortcut for it because Shift+ ° doesn’t work for me either.

Yes, very strange and possibly wrong translation.

I think the translation is very accurate.
„Hide invisibles“ means exactly „Unsichtbare ausblenden“

The function sounds in English as mysterious as in German :wink:

The Mac version for the German language (Shift+°) didn’t work for me either until I did the following: Change the keyboard language in Preferences > Keyboard Shortcuts from “Standard” to “Deutsch”

Welcome to the forum, hofes!

This is only necessary, when you set your language to something else than German. :slight_smile: