3rd party plugins appear small on 4K screen

While Cubase plugins appear normal, 3rd party plugins appear very small.

I enclosed two images so you can see the difference between 10.5 and 11


This is also the first thing I tested since this is THE feature I was waiting the most for Cubase 11. After clicking on the “Allow plug-in to be resized option”, many plugins now appear great. Some however still appear very small, with huge black space around. It’s just the graphic display however, for real, the plugins themselves are resized, and respond to controls where they should be. For example, check the screenshot here, when I click in the middle of the black in the low right corner of Ozone Neutron, it activates the bypass even if it shows in the upper left corner:


Testing so far, by manufacturer, based on plugins I own:

Working, after checking “allow resize” (initally too small)

  • Softube


  • Sonimus


  • Sonible


  • Sonarworks


  • Accusonus

Working great out of the box, and no “allow resize” option even showing (??? why):

  • Sonnox


  • Spitfire Proprietary Plug-in(not Kontak)


  • Arturia (EDIT: I didn’t know about the native plug-in resize option, my bad)

Not Working:

  • Izotope

I mean, it’s already much better than it was, but any ideas why those last don’t work? Yes, it’s easy to throw the blame on those developers, but neither, especially Izotope, is a small company that botches its UI code, and both plugins have shown perfectly resized in Ableton Live for years on my 4K display.

After a quick look.

Waves work - change the zoom within the plugin, waves background are a bit grainy but that’s a waves problem
Arturia work - I have no problems with Arturia, set the zoom in the plug in, no need to touch the cubase ‘allow plug-in to re-size’ option
Roland Cloud work - again set the zoom natively within the plug in
Toontrack (SD3) work - appeared to behave as it should

NI Kontakt looks awful. I don’t know whether being able to click the ‘reset interface’ option within the Kontakt options would help but once you click the ‘allow plug-in to re-size’ option in cubase, the button for that Kontakt ‘reset’ option is outside the area that is shown, so can’t be clicked.
Confirm Izotope don’t size. I can’t find an option to zoom the gui natively within the Izoptope GUI. Using the cubase ‘allow plug-in to re-size’ option, just leaves a small plug in gui surrounded by black space.

I’ll check more later.

edited to clean spelling/grammer

  • Edit
  • Preferences
  • General
    I switched OFF HiDPI and stuff looks like it supposed to look on my 4K monitor.

“I switched OFF HiDPI and stuff looks like it supposed to look on my 4K monitor.”

Yep, this is what I did. Seems mad, but it works.

If you turn it off then Cubase is not taking advantage of the fantastic DPI that your 4k monitor has. Cubase and all the plugins that support resizeable GUI’s look so much better with HiDPI on. So far I’m only having issues with Native Instrument and Izotope. Most of the other major players work fine in HiDPI and either scale the GUI using the plug-ins built in option, or use the the Cubase ‘Allow plug-in to resize’ option for those that don’t have it baked in to the plug-in.