4.5.1 visual corruption

This never happened in the 4.5beta release, but in the 4.5.1 official release, dragging and dropping nki files from the new browser tab onto slots, causes the GUI of Halion 4 to turn a solid grey colour. If I click on the grey parts, the proper gui section comes back from underneath it, but then turns solid grey again as I am working. Really annoying when the quick controls, keyboard etc turn solid grey and you can’t see what you are doing.

Anyone else?

I’m going to guess and say that .nki behavior in Halion may not account for NI format update which occurred at Kontakt’s 4.2 release (afaik) when there was a format overhaul at that time.

I haven’t been able to import any of those VIA Halion loader directly.

Translator will easily handle them though, and I have done so many times already.

Halion will handle them just fine (for the most part, some sample start/end points are a little off etc). They get imported, mapped and playback just fine. As the conversion progress takes place however from nki to VST Preset the GUI of Halion 4 goes wonky and all sections turn solid grey. This didn’t happen when I imported nki from the browser tab in the 4.5beta however.

I can confirm that NONE of the the NI resaved programs after 4.2 will load. They get the red icon beside them in the Halion loader.

I tried loading and saving a couple pre 4.2 programs and didn’t get the issue.

This has to do with the presets being protected.

Can’t reproduce here … all .nki’s load perfectly via drag-and-drop except of course protected content. Self-built .nki’s are all loading, but .nkb’s naturally not.

Strange. Thanks for the confirmation. You are dragging and dropping straight from the newly included browser tab in Halion 4.5.1 correct? Not from anywhere else?

I will take a snap shot the next time this happens and upload so you will have a visual to my description.

Again, the loading is fine sample wise, it is just the graphics that go wonky on the GUI of Halion 4 when this is taking place (the loading and conversion).

[EDIT] Forgot to mention, H4 x64 only, on W7 x64, haven’t tested (or even installed) the 32-bit VSTi.

ok thanks for your report. I will need to get a screenshot of this to prove what I am seeing. I am using Win 7 X64, but 32 bit Cubase 6 and Halion 4.

On my system I can drag and drop any preset - not protected from Kontakt 4.2 content to HALion 4.5.1, directly from browser of HAlion with any problems.
Win 7 64 Prof., Cubase 6.0.5, HALion 4.5.1, Kontakt 4.2.4. 5316, Intel I7, Gigabyte motherboard, 12 GB RAM, NVidia video card, M-audio Pro Fire 610, M-Audio Midi Sport 2x2.

I think I have found the issue to this problem, though need more time to play and confirm. I feel it has to do with setting the multi-core option to 8 in the options tab of Halion 4. I have a quad core with hyper threading which has the drop down menu of the multi-core option showing 8 cores. I naturally selected 8 cores to get the maximum performance. I did this from the start so never had a basis to compare various other settings to. I started getting this visual corruption when loading FXP presets, even from just dragging and dropping VST Presets from the Halion 4 mediabay into a slot for use. It was no longer limited to simply importing NKI presets. Cubase 6 would often times lock up at this point throwing a pure virtual call crash forcing me to hard close the program through task manager in Windows. For shits and giggles I tried to lower the multi-core from 8 core to 7 cores. It has only been a day, but so far no issues whatsoever in terms of visual corruption or lockups/crashes when loading presets into Halion 4.

Hopefully it keeps up this way. I will reply here if anything changes.

ok, this isn’t the case and something else must be up. Though the visual corruption has been minimized with changing the cores from 8 to 7, I had it once more this morning while dragging and dropping a preset from the Halion 4 Mediabay into a slot. It never crashed Cubase this time however and loading another preset afterwards cleared up the visual grey, missing texture issue. :cry:

I am still getting this grey screen corruption pretty badly from time to time. I finally managed to grab a screen shot to upload for all to view and give your feedback.

This is happening upon dragging and dropping anything from a secondary Halion 4 window into the main Halion 4 window, being VST presets from Mediabay, WAV files from the sample browser etc. Anything and everything will cause the behavior noticed in the attached picture. It is not just NKI like I thought and it has nothing to do at all with core selection for mult-core use in the options tab.

Is the secondary HALion 4 window located on a second monitor or did you noticed this behaviour in a single monitor environment (all windows are on the primary screen) too?

best regards

Hi Gerrit, thanks for your reply in this thread.

The above anomaly takes place when dragging and dropping from a Halion 4 window located on a secondary monitor, dragged into a another Halion 4 window on a primary monitor. I had un-docked a window with select tabs to be placed on my secondary monitor, while leaving another Halion 4 window with other tabs on my primary monitor for ease of organization and my workflow style.

It may come in handy to note that my secondary monitor is actually pivoted 90 degrees, so as to have it more vertical than horizontal. This comes in handy for the Mediabay tab where a maximized window gives me 24" of vertical preset listings. It also comes in handy when opening the zone tab of a selected sample as it fits every single section of the zone tab in view without having to scroll at all to get at the lower components such as the step modulator and mod matrix.

This behaviour only started sometime around the 4.5 update. I never noticed it on 4.0 or 4.01. I do not get the above problem when dragging and dropping from the Cubase project into Halion 4, or from content located from within the same window/monitor. Dragging and dropping presets, samples etc from my secondary monitor, into my primary monitor is what causes the solid grey background to appear.

If you need any more info or descriptions, please let me know, I would love to help get this annoying problem solved.

Thanks again for your time,


Finally we were able to reproduce the problem here. It will happen if you drag files from an undocked Browser window “over” the Mapping-Editor into the Slot-Rack.

This problem will be fixed with the upcoming HALion Version 4.5.2

best regards

I also had this from time to time but couldn’t find a way to reproduce it reliably.

Thanks for the update Gerrit, it seems that Halion 4.5.2 will solve all current issues :smiley:

Fantastic news Gerrit. This was the one, most annoying thing I have had happening to me and to have it fixed will be a real blessing. The Mediabay Family text entry issue being fixed is another great thing.

Bring on 4.5.2! Great job Steinberg!

Confirmed to be addressed in Halion 4.5.2, what a relief! Great job Steinberg!