480% cpu usage Mac


Running Cubase Pro 10 on 6 core Mac mini with 32 gb ram.

Can put about 6 tracks of any given soft synth with one eq and cpu spikes out.

This is on a clean install of both the OS and Cubase.

All settings are default. 256 buffer ,ASIO guard on, 32 bit, etc. setting the buffer to 512 doesn’t help much.

When I look in the Mac task manager Cubase is using over 460%. Everything else is at 1% or less.

Thanks for any help. I’ve tried every other DAW out there, but Cubase has it all and is the workflow for me. Hopefully I can sort this out.

Hi and welcome,

As far as I know, this is how does macOS presents the data in general. The % is counted from 1 core. So if the application is using 2 cores for 100%, it shows 200%. If you have 8 cores (for example), your maximum is 800%.

CPU usage is not saying that much on modern CPU’s that have CPU clocks that goes up and down very quick.
Intel has a tool called “Intel Power Gadget”. I guess that you have the i5 variant with usb interface since it seems to be common problem with T2 chip and low latency audio. But some channels claims that is is fixed.

So that makes sense why the Mac Activity Monitor Reads like that, but what issues/settings do I need to fix to get more than 6 instrument tracks to work?

I downloaded Logic Pro X and was able to put 40+ tracks with a software instrument and an eq before the cpu started to spike.

Why the disparity? Like I said, would much rather use cubase.

Thanks for everyone’s help!

Here’s where I currently sit after messing with a bunch of setting right now:

Going from a buffer of 256 to 512 helps very slightly.
Doesn’t make a difference whether I use 32 or 64 bit.
Audio priority boost helps very slightly.
ASIO Guard off is what helps the most.

Was able to get 32 Instrument channels running Massive X while freezing 12 of them (instrument only), and still have a little bit of room to maneuver. No dropouts.

I can live with that. I doubt in a real scenario I would ever use that many instrument tracks, and if I did I would probably be freezing more than just 12.

I will definitely keep trying different things and see what helps.

Any other advice is always appreciated.

Asio guard off??? How many tracks are armed for input? Take notice of what happens to the real time performance (F12) when you unarm/arm the track at different ASIO Guard modes, on and off. ASIO Guard is a handy feature so that we don’t have to keep swapping buffer settings depending on tracking or mixing. The unarmed tracks are at a higher buffer. Once arming a track it will jump to the tighter buffer (current ASIO setting) for a better “real time” input performance. Depending on the Synth and how demanding the preset is, this is more likely to result in ASIO spikes.

For more power, to avoid spikes, unless you are playing a midi controller, don’t arm tracks. In the settings you can change if selecting a track auto arms or not.

Try with a synth not Massive X… Massive X requires AVX compatible processors. AVX is very demanding on the CPU. A lot of CPU’s are set in the BIOS to step down under AVX load or not turbo as high. In my BIOS this is AVX OFFSET, not to be confused with Ring Ratio (which can be the same frequency). I don’t have Massive X to test how this impacts. I don’t know if Massive X actually uses AVX or if they locked it to CPU’s that have that, them being newer, as away to insure people don’t try to use Massive X on inadequate machines.

With ASIO Guard on, buffer set at 256, only the armed track will be at a 256 buffer, the rest will more like 512. That might be technically incorrect but it’s the easiest way to explain it. Not all tracks use ASIO Guard (at least in the earlier version of it).

HOWEVER, regardless to all that, you should still be getting better performance.

What CPU do you have? What is it’s base? What is it’s turbo? Have you locked it into turbo? What clock have you locked? Does it current throttle? Does it thermal Throttle?

Yeah, that’s with only one of the 32 tracks armed and the 12 frozen, ASIO guard off, 512 buffer, audio priority boost.

The way I determined this was intentionally using an instrument I knew would take up a fair amount of power, then having the Cubase cpu meter and the Mac activity monitor open side by side and going through setting after setting to see which combo provided the best results.

Like I said, I would probably never use 32 instances of a software instrument most likely, and with the above settings I was also able to add four fx tracks with two plugins each on them, and duplicate an audio track six times with two reverbs, a compressor, an eq, and a flanger on them without spiking and dropouts. So for me, for now, that’s acceptable.

It’s a 6 core i5 Mac mini with 32gb ram. I will say it does get warm and the fan does come on, but it doesn’t come on like it did when I tried to run 32 tracks with none frozen and ASIO guard on.

I do wish Steinberg would sort it out on the processor usage. I know Apple has the advantage with Logic being their own, and hence I was able to get 48 tracks without freezing. But I’ve tried them all, and Cubase has been the one for me. Looks like it’s time to start saving for a new Mac Pro (if the CPU is also upgradeable). But for now, the setup I have is acceptable if I make freezing tracks my best friend. (Hey Steinberg, make it so we can freeze more than a track at a time.)

Thanks everyone.

ASIO guard on should give you more usage. This is because only one track, the armed track, will be at the buffer setting you have set, the others will have a higher one, more time for the cpu to compute what it needs to, as if the project was more like 1024. With ASIO guard off, all tracks, regardless to being armed or not will be at the tighter buffer setting.

It doesn’t matter if it’s a 6 core i5 mac mini, what matters is what i5 chip of that generation it actually is and what the frequency is set to. Are power saving states disabled? Are you clocked into Turbo? Can it deliver stable voltage at high clock speeds for duration and can it keep itself cool when under load.

That would be expected.

They have, there’s something not quite right in your set up

EDIT: MAC MINIS really don’t clock very high. They’re not very god at all, price considering!

That would be a mistake, unless you have money to burn.

Thanks! I’ll try and respond when I get home from work and give some pictures of the settings and cpu usage.

I appreciate you trying to help me sort it out. Much better than the Steinberg response I just got of raise the buffer and try the settings from our MacOS Optimization page.
As if those setting aren’t on every website for every DAW under the sun out there.

That’s a 2018 MacMini? If so, that’s a killer machine for music production. Big cpu bang for the buck.

First thing: the system activity meter is a poor indicator of DAW cpu usage. Instead, you should be watching the audio processing meter in cubase. Second: Assuming the cpu meter in cubase shows more usage than you expect, you should examine your expectations. Exactly what are you using in the project that might be contributing to the cpu load? Third, if there is indeed a problem, be methodical and systematic trying to troubleshoot this. Use process of elimination to remove plugins to determine if there is a single plugin that is the cause of the problem. Eliminate your audio interface by using the headphone jack for your output to see if the audio interface is the source of the problem. Turn off asio guard while you’re troubleshooting.

It really isn’t, that’s a 3.0, 6 core i5 8500, for just over £1000, inadequately cooled for durations of fast turbo. That price is only 8gb of ram and 256 PCIe NVMe version.

In 2018 for just less than £900, i got an 8 core i7 9700k, clock locked and stable at 5.0, top notch expensive Noctua Cooling. 32gb of ram. 512 Samsung PRO PCIe NVMe (not the half price evo).

With it not being the K, I’m not even sure it can be clock locked in turbo. And, even if it could, temps would be an issue, current would be an issue. There’s no way that thing has the solid stable well cooled VRM’s of an actual high quality MB (that you would get at that price).

It’s a good chip but for the price, underutilised, due to what it’s connected to. Synths like Avenger and Massive X will easily hit ASIO spikes, especially if there’s inserts, buss plugs and mastering stereo processing on 1 chain. The 4.1 turbo after any length of duration is going to be unattainable. Even worse in warmer climates.

My 6 core i7 16GB works great for the money. It’s the sweet spot in Apple’s product line for music production right now. I don’t have any temperature problems and I run much heavier instruments than Massive :slight_smile:.

In any case, I don’t think the issue here is Mr. Versicolor’s choice of computer. He should be able to run 6 simple tracks.

The macmini i5 is not exactly a speed daemon. If you need speed and have the money, an iMac Pro or even the normal iMac 2019 with i9 CPU are quite a bit more powerful.

It’s Massive X, which is entirely different, it’s locked to AVX compatible CPU’s. If it actually uses AVX, because this type of code tends to generate more heat for a CPU, a lot of BIOSs have an offset to run at a slower speed whilst processing it, regardless to how much load or heat you’re currently generating, it’s an AVX auto offset.

Whilst I doubt AVX is the issue, it’s something to be aware of when trying to tweak max performance.

The extra .2 on the i7 will tip closer to needed. .5 to turbo but I’m not sure how well the turbo performs on those machines. Do you disable power saving modes in the BIOS? What clock does a project idle at?

When I first clocked my machine to 5.0, locked (not dynamic). A Cubase project at idle would still randomly clock down to 4.7. This was due to current throttling, incorrect ICCmax, temps fine, fans not even span up. If underload, I suspect any kind of similar step down is going to cause ASIO spikes, even though the machine should run the project perfectly fine, especially a 3.0 base, any step down will be disastrous.

Totally, there’s definitely something not quite right.

Something is totally fucked up with freeze. When freezing any track my read-time performance load goes up a lot. It’s like that friezed track does NOT go through the ASIO guard.

Guys, thank you. I never knew about armed tracks smashing my CPU.

I just set up a Mac mini and it was as slow as my old imac. It’s cranking now that I have changed my prefs!

Fiddling with ASIO guard etc barely made a difference.