4K monitor + 150% + "Show Application in High DPI" = incorrect plug-in window size

This case is for WaveLab 9.5.40 on Windows 10 Pro version 1809.

  • Monitor is a 3840 x 2160 monitor
  • Windows Settings > Display > Scaling: “Change the size of text, apps, and other items” set to Windows recommendation of 150%
  • WaveLab > Preferences > Global > Display > Miscellaneous Options > “Show Application in High DPI” is checked

In this scenario, most of the WaveLab interface renders quite nicely. However, when opening plug-ins, the framing window that WaveLab draws for the plugins is much too large. Here are a couple examples:



If I turn off WaveLab’s “Show Application in High DPI” then the plug-in windows are fitted correctly to the plug-ins, but the WaveLab interface is rendered with small type and details and it’s not as usable.

If I leave WaveLab’s “Show Application in High DPI” on but change Windows’ scaling from the recommended 150% for this monitor to 100%, WaveLab also draws the plug-in windows correctly around the plug-ins, but the WaveLab interface’s type and details are rendered so small as to be completely unusable.

This monitor is manufactured so that it works best with 150% scaling; hence, the Windows recommendation is 150%.

What I would prefer is for WaveLab to be able to work with Windows’ recommended scaling and draw the plugin window correctly.

Any thoughts?

This is just a wild guess but if Wavelab uses the Qt framework like Dorico, then it might be affected by Qt’s bug that will always round scaling factors (so 125%/1.25 will be rounded to 100% and 150%/1.5 will be rounded to 200%), see https://www.steinberg.net/forums/viewtopic.php?f=246&t=117661#p779973

Until Qt resolves this problem, it appears to be rather difficult to work around this, so perhaps while the main window does it, the plugins can’t?

Pietzcker, thank you for the notes and link.

Philippe, do you have any additional thoughts on this?

Would love to get some additional feedback.

150% ratio will come in the future, but not in the near future.

Philippe, thank you for providing this response - much appreciated!

In the meantime, are there recommended settings? 4K monitors are now a part of our normal studio environment and 150% is the Windows default. One more-irritating issue I’m having is that all the plugins either open way too wide, or (more commonly with VST3) WaveLab will draw them too large and cut in half (so the rest of the plugin is not visible). Various settings I’ve tried work only part of the time. Any workarounds you’d recommend?