5.0.1 to 5.5.0 (and then 5.5.3) update crashing.

Good afternoon,

Sorry, we’re a bit behind the times in terms of updates (isn’t education wonderful)!

We have ~35 XP sp3 machines on an RM CC4 network with Cubase Studio 5.0.1 installed, and I’m trying to update them to 5.5.3. First, I’m getting it working on one machine first, so I d/led the 5.5.0 and 5.5.3 updates to that machine. I tried running the 5.5.0 update executable, and it proceded to install the new VSTs (beatbox? I can’t actually remember), then after that had finished, it exited. I thought it was a bit to have finished, and sure enough, when I run Cubase again, its still on version 5.0.1. I tried to run the 5.5.0 update again, and it brought up a ‘loading’ bar, then closed itself as the bar reached 100%. Just out of curiosity, I tried running the 5.5.3 update too, but the same happened - it loaded to 100% then crashed to desktop. No error messages or anything. I was logged in as an administrator (although I haven’t tried local admin yet, just domain admin).

I tried search the old forums and google, but couldn’t find anything similar, and attempts to search this forum are made a little difficult, what with ‘update’ and numbers being ignored by the search function :stuck_out_tongue:

Any ideas?

If you are game, you could try unpacking the installers into their requisite components and installing things individually.

You know, I didn’t even think to try extracting them! Good shout, thanks. That’s tomorrow’s job then!

This way patching is done separately to installation/upgrade of components.

Hm, ok, got a bit further.

I now (when running ./Autoplay/Docs/Cubase_Studio_Patch_550.msp) get the error:

The installation source for this product is not available.
Verify that the source exists and that you can access it.

The disk is in the drive, I can browse through it (and indeed, have just re-installed cubase studio 5 from it) and I’m still logged on as domain admin.
I guess it’s looking somewhere else for the cd(?) but I can’t find any prefs or registry entries pointing to anything like that. My next option is to rebuild all 30-odd machines, reinstall cubase on them and hope for the best…

And running

msiexec /p <patch> /a <msi>

fails to find a file - VST3PR_Gate_424 from InstallFiles.cab and rolls back.

another edit:
Ah, I’m a pillock. Uncompressing the CubaseStudio5.msi with

msiexec /a "Cubase Studio 5.msi" /t uncomp

will dump the contents into the directory ./uncomp, then

msiexec /p Cubase_Studio_Patch_550.msp /a uncomp\CubaseStudio5.msi

then it installs 5.5.0 into a directory of your choosing.

Now I’ve just gotta see it 5.5.3 is as easy!

Ok, just to finish this off for any googlers…

  1. Install Cubase Studio 5 from CD/network share/whatever

  2. Grab the CubaseStudio5.msi from the CD, and the update files from Steinberg.

  3. Open the update files with 7zip (or similar), and grab the relevant .msp’s from ./AutoPlay/Docs/ (32 or 64bit)

  4. Uncompress the CubaseStudio5.msi into a new directory ‘uncomp’ using

msiexec /a "Cubase Studio 5.msi" /t uncomp
  1. Apply the 5.5.0 patch to the uncompressed .msi with
msiexec /p Cubase_Studio_Patch_550.msp /a uncomp\CubaseStudio5.msi

I put the output into a new directory ‘patch550’.

  1. Copy the CubaseStudio5.msi into the 'patch550; directory, then apply the 5.5.3 patch using
msiexec /p Cubase_Studio_Patch_553.msp /a patched550\CubaseStudio5.msi

Again, I dumped the output into ‘patched553’.

  1. Almost done! Copy the contents of ‘patched553’ into ‘Program Files’, overwriting the installed Steinberg folder (after making a backup, if you don’t want to reinstall again in case of problems)

  2. Use the original shortcuts on your desktop/quicklaunch/start menu to run your new shiney 5.5.3!

In my case, I’ll be running one machine as a test rig for a week or so, just to check it all works properly, then distributing it across the rest of the machines.

Thanks for your help!

Dear Guest!!
I have been trying to get our network guys to run cubase 4 on a CC3 network and now a CC4 network for several years.
We had a problem with the cubase defaults.xml taking ages to write or hanging and generally as a results screwing cubase. For some reason RM force the defaults.xml file to write to the users my documents, my settings application data etc, and the 437KB xml file is taking 60 seconds to write.
Have you had the same problem and are you willing to have a chat with me to find out how you’ve managed to get cubase to run successfully on a CC4 network?

We had in the past had dual build on the CC3 machines so we could work cubase locally, but CC4 doesn’t allow dual boot
You could be a life saver