6.0.5 and Sluggish Cubase

Anyone else still have a sluggish Cubase in terms of it’s response time to double mouse clicks or keystroke entries ?

Mines gone this way, it takes a few attempts to open a say a MIDI Clip by double clicking it in the project window.

Or if I am naming a new audio track for example, I have to type really slowly or Cubase won’t pick up half the letters.

My CPU is barely being taxed, my ASIO use meter is about a quarter used, RAM is fine, and i’ve just put in a brand spanking new GFX card three times as good as my old one. So my system isn’t strained, but this is wierd.

Cubase itself works fine, plays back with no stutters, no issues with CPU spikes, nothing bad going on, just sluggish to respond to the mouse or keyboard.

Could it be that your key+mouse is wireless and it’s too far away, or low on batteries? I’ve had several different editions and none of them work 100% reliably for me!! I once had to bluetak the USB receiver onto my keyboard to get it to work :smiley:


Gotta love blu tak, comes in handy in the strangest of situations :slight_smile: lol

Alas no, both mouse and keyboard are wired, so no issues there.

Although guess what, I have a funny feeling it’s good old Automap from Novation. I exited from Cubase, mouse was still sluggish, so I checked my task manager and the only audio related thing that was still running , yes you guessed it, your friend and mine, Automap, so I close it down and hey presto, mouse is back to normal.

I’ve had nothing but problems with it since I bought my nocturn, and tbh if I had known the nocturn was 100% reliant on Automap i’d have never bought it. Glorified paper weight on my desk.

Nope, I can’t pin it on Automap, even though that was crashing non stop, turns out there was an update to 4.2.

OK, so I am back to square one. it’s a sluggish pickup from the mouse and keyboard. I’ve no idea what could cause that.

Have you done a virus check? Also, you could try to disable the networking - not a long term solution but something to narrow it down. Also, anything in startup that is automatically starting? Have you updated your graphics card drivers, and mobo drivers, and OS, etc.? You should state what your system specs are too, although I’m pretty much out of ideas.


I’m pretty outta ideas too, everything is up to date, although I am thinking this is since I went from an Nvidia card to an ATI, so must be some issue when stretching Cubase over 2 windows using the Catalyst drivers. Maybe I need to look into them a bit more for better optimization.


Windows 7 ultimate 64bit.

AMD Phenom II 3.2gz hex core

8 gig RAM

Anyone use ATI cards and the Hydravision addition ?