60fps with H.264 encoding

Hi,

I am a composer working for a sound and music for video games company. We really need to find a way to use the right encoding for our video captures. The thing is, our sound designers want to work in 60fps and it kind of makes sens when working with video games.

Now most of our sound design team are still work with Cubase 8.5 or 9 because H.264 works great at 60fps. The video engine switch in Cubase 9 our 9.5 can’t remember, was a disaster for them and I kind of agree.

For me, I’d be fine with 24fps but we need to find a standard render setting for 60fps that everyone in the company can use and we’d be glad to upgrade all the stations to Cubase 10.

We’ve tried the DNxHD extra licence and it works but file size are gigantesque and not an option since we have hours of gameplay of video captures we have to work with.

I have gone through the Steinberg recommended encoding settings for H.264 and all seems to be in order. I’m converting with XMedia Recode with all the B-Frames and P-Frames and frame interval suggested settings. I’m still not able to get a working 60fps H.264 playback in Cubase 10. No issue in Cubase 8, just saying.

His anyone successfully working with 60fps H.264 in Cubase 9.5 or 10.

If so, please share with us your encoding secrets!

Cheers,

What kind of problem are you experiencing with 60fps H.264 video files?

Usually I work with 24fps (cinema) videos.
But I’ve just tested again some 60fps files without any problem:

720p 60fps and 59.940fps videos: smooth playback
1080p 60fps video: not smooth here on my machine (it probably depends on computer’s power).

All videos: MP4 H.264 16:9 (NTSC)
Video stream: AVC
Audio Stream: AAC LC
Profiles: Main 3.2 for 720p (bitrate ~8-9 Mb/s), and 4.2 for 1080p (bitrate ~36 Mb/s)

Clips created with either Premiere Pro or Vegas Pro.

Edit: same results with files encoded using XMedia

I get not playback at all. It plays a few frames and then the video freezes. The funny thing is that if I seek using + -, it’s pretty smooth and it does not lag. I think I can attribute this to setting key frame intervals to 1 when rendering.

I conformed all settings in XMedia Recode and other NLEs to Steinberg recommendations: no difference, video playback is again smooth with any setting.
The problem seems to be elsewhere.

Perhaps you could provide a sample of your videos.

Really? In 60fps? I’m happy to hear it’s possible.

I remember having performance issues since I switched to a 4k resolution display in windows (videos are 1080p). I’ll try with a lower resolution if the issue persiste. I’ve spend 2 hours trying different settings including the recommended ones for H.264 in 60fps and nothing did it. I use a geforce GTX 1060 the 6gb version and I have a pretty good system. I doubt it’s my hardware. I’ll see what I can do for a video sample.

I can confirm that it still does not work even when I lower my main monitor’s resolution to 1080p.

Here are the settings I’m using in XMedia Recode :

General :

MPEG-4 AVC /H.264
Framerate : 60
Rate control mode : ABR (Average bitrate)
Bitrate : 10000
Keyframe Interval : 1
Display mode : Progressive

B-Frame :

Number of B-Frames : 3
B-Frame mode : None
Adaptive B-Frame : Fast
B-Pyramid : None
Weighted B-Prediction : Un-checked
B-Frame bias : 0

Am I missing something?

Thanks for the help.

OK now I see.

Apparently the problem is the resolution/framerate combination playback limitation.
1080p @ 50 fps and higher resolutions/framerates won’t play correctly as far as I can see.

720p @ 60 fps plays fine. Maybe you could use this format for the moment, hoping for future video engine improvements.

I did not realize that. I’ll try right now! Thanks for the help.

480p is even much lighter on the system and still plenty detail if downsized fromHD or 4K. Since the load is squared from size (width times height) it rises and drops very fast with size. Of course file sizes are equally affected.

I can confirm that it solved my issue here. I got 60fps videos to work well in Cubase 10 when dropping to 720p. Thanks you very much for your help. I hope Steinberg finds a way to optimize this new engine at some point. It’s still outperformed by Cubase 8. And I spent a few month working with Reaper last year and it’s video engine (VLC) also outperformed Cubase 10’s engine.

At least now I know it’s limitations.

Thanks again!

Playing video back within Cubase will always use precious CPU that could be better put to audio use. For anyone who has the time to experiment, one solution is to play back the video on a seperate device, synced to Cubase via network using MTC. That could be a spare laptop for instance, following this suggestion from fellow user jorisdeman.

(You will have figure this out for your own setup, every one will be slightly different – I can’t help you there!)

Not sure I agree with that. Sure it takes a small amount of CPU to playback a compressed video but a lot of other DAWs do it without a fuss. Reaper is using VLC as it’s engine and it’s super light on CPU. Having a slave pc for something as simple as video playback seems a bit extreme. Especially since it all worked well before Steinberg switched engine a few years ago.

Don’t get me wrong, I’m not defending Cubase, nor am I happy with the degradation in video playback in Cubase in recent versions, it’s just that there are other ways to approach this. If you follow the above post, it’s also possible to sync the video to the player on the same machine, and it will still be better than within Cubase. Needless to say there’s an investment of time in order to get it all working, but it will handle more formats and handle them better.

Thanks for the tip. In the end I’m all about exploring different workflows.