64 bit version of Wavelab 8 not opening on 64 bit Windows

Does anyone know why a 64-bit version of Wavelab 8 wouldn’t launch on a 64-bit version of Windows 10?

I recently upgraded my machine, moved over the dongle and tried installing Wavelab 8 on the machine. While I can install both the 32 and 64 bit versions, only the 32 bit version will launch. The 64 bit version does nothing.

I have Cubase Elements 8, 64 bit, on the same machine and that works splendidly, and I had no problems with Wavelab 8 on Windows 7. Seems odd that on a 64 bit windows machine, Cubase 64 works, but not Wavelab in 64 bits.

Also, I tried to do a search for this info, but returned zero hits as apparently 64 bit is a really common search.

Well, ofcourse it -should- work, and does for many others. So you say the 64 bit version ‘does nothing’. What happens when you try launching, and how do you launch it?

Thanks, Arjan. I installed it by the installer wizard, which leaves an icon on the desktop. I double click it and… nothing. If I double click the 32bit version of Wavelab, it launches with the splash screen, etc., as does the 64bit version of Cubase.

You could try going to Program Files > Steinberg > Wavelab 8 and double clicking the Wavelab .exe in the program folder. It could be a bad desktop shortcut.

If that doesn’t work, you could try resetting the preferences.

Thanks for this. Unfortunately, it didn’t work.

Which preferences do you mean?

This is on Steinberg support for Cubase and Nuendo but it works the same for Wavelab.

under Initializing Preferences:



Or, reinstall Wavelab.

Thanks, all. I tried the preferences edits and reinstalling Wavelab; still no dice.

Are you using the latest version? This is 8.5.31, found there: