8.5.15 and Komplete Kontrol track follow not working

I’ve researched this quite a bit through forums and knowledge base on NI and can’t find anyone with the same issue. In Cubase 8.5.15 and Komplete Kontrol 1.5.1 with driver 4.2 for the S61, the track follow feature isn’t working:

When I create an instrument track with Komplete Kontrol, I get the browse option on the S61 screen and can select my instrument with its parameters showing on the S61 screen. If I create a second instrument track and load komplete kontrol, I get the browse menu screen again and can load an instrument with its parameters showing. Once I switch back to the first track, the parameter screen will update to its values, however, if I go back to the second track, the parameters do not update. They stay on track one. The only way to get the S61 screen to update is to mouse click on the keyboard icon on the Komplete Kontrol software for that instance.

The weird thing is that if I make other non-Komplete Kontrol instrument tracks, the S61 updates to the general midi screen for each. But If I have say 10 Komplete Kontrol tracks, it always switches to and stays on track 1 parameters after I create the extra tracks and move to another one. So If I create track 8 for example with Komplete Kontrol loaded, then switch to track 7, the S61 screen switches to track 1 parameters. And FWIW, the arrow keys on the S61 do allow me to switch tracks, but the parameters still remain on track 1.

So I’ve gone through the usual steps of verifying the Mackie Control device is setup per NI’s guide https://www.native-instruments.com/en/support/knowledge-base/show/2797/setting-up-steinberg-cubase-nuendo-for-komplete-kontrol/ I only have the one MCU device. I’ve tried resetting that device page after starting Cubase as I have read other users do, I’ve uninstalled everything, Cubase and Komplete Kontrol with driver, reinstalled them. I tried on an earlier version of Cubase, 8.0.3, and it didn’t work either.

I do notice that I cannot install the Komplete Kontrol 4.2 driver on its own. I get the exclamation marks in Windows Device Manager next to the S61 device after installing. But if I install the Komplete Select software that has the driver integrated, then the driver successfully installs. Either way, the track focus doesn’t work. Anyone successfully got this working in 8.5.15 or have a fix on this? I think something deeper within the Komplete Kontrol install isn’t talking with Cubase correctly, or maybe I flipped some obscure setting in Cubase to cause this. Cheers!

Same issue with the same environment. Cubase 8.5.15 and Komplete Kontrol 1.5.1 with driver 4.2 with s25
Did you found a solution?

And I have the same problem also in 8.5.20.

BR
Daniel

Wow just when i was about to drag and drop my stems to Cubase 8.5.20 i have 1.6 update for KK this will slow my process down

Having the same problem… has anyone found a fix

Enable ‘Set Remote-Control Focus for VST Quick Controls’ , like in the image attached. Now, try to browse between tracks. Hope it helps.
SetRemoteControl.jpg

Can anyone confirm whether this solves the problem? Want to pull the trigger on buying one of these controllers but it’s basically entirely based around whether light guide and keyboard parameters update as you navigate from track to track.