8.5 Crashing with Arturia Arp 2600 V2

Arturia Arp 2600 V2 crashed 8.5 with cascading error messages then on quiting 8.5 Blue screen of death.
Now can’t load stand alone version of Arturia Arp 2600 V2 or VST version without crashing the program.
Click on the stand alone nothing happens.
Vst version cascading error messages again.

Uninstalled Arturia Arp 2600 V2 & Cubase 8.5.
Reinstalled 8.5 & Arp 2600 but problem persists.

Same happens even on fresh project.

All worked happily before Cubase 8.5.

Has anyone got a fix for this.


Do you work with the dongle or with the softwarecenter from arturia? Updated to the last version?
If the standalone version crashes too, it is not the fault of cub8.5
Here is no problem with all instruments from arturia wether vst in cub 8.5 or standaloneso i dont believe that is cub8.5 is the culprit.


Make sure the plug-in (and software) is up-to-date. Most likely, this is on the plug-in side.

The Arturia synths were notoriously buggy and unstable whilst they used eLC for their licensing, since they moved over to their own system there has been a massive reduction in issues, not had a chance to test the ARP on 8.5 yet but i will try later to see if i get the same issue.

Just run it for half an hour or so with no issues other than when i run Cubase in non-admin mode i get the occasional nag screen that the synth isin’t registered (which of course it is) but if i click demo mode all is well… i also got a crash on exit (win event viewer states it’s ntdll.dll causing the issue)but that happens occasionally with Arturia synths too so nothing out of the ordinary this end, that’s with build which i have yet to update to which is the latest build, which build of ARP2600 are you running?

Hi matjones,
Thanks for your help.

Im running the newest as I got the Native Instruments/Arturia offer recently.

Posted the issue with Arturia also & they think it could be a Registry problem so will do a Registry clean.
Can you suggest a good Registry cleaner as have never done before on my DAW.
They also suggested that if that didn’t work to load an older version of Arp 2600.

It was working fine untill the Blue screen, never had that before.
I wonder if somehow it has now been Blacklisted by my PC.
It’s weird how the Stand alone version is affected.
All the other Arturia stand alones & vst’s are fine just Arp 2600 V2.
Thanks again for your help.

Hey Mike!

No worries mate…
Yeah an earlier build might be worth a try, i’ve not updated to the latest versions as there seem to be a few issues with C8/8.5 from what i’ve read in the forum over there and my V Collection seems to be reasonable stable at the moment.

i used to use C Cleaner a while back but i prefer to do registry tweaks manually so i know EXACTLY what’s been tweaked. if you mess with your registry make sure you back it up before you alter anything in it, apologies if you know this already.

From memory the standalone versions are all 32Bit so not sure if that might be a pointer for you, i’d definitely try an earlier build before you touch your registry though.

Sorry i can’t be of more help… hope you do manage to get it sorted because those synths are a hell of a lot of fun when working!

Hi matjones,
Older version doing the same thing possibly worse as it crashes Cubase all versions from 6 to 8.5.
Am at a loss as other Arturia stand alone & vst are fine. Weird.
If I have to live without Arp 2600 V2 then I guess I will have to.
Seems like the Pc which is a purpose built DAW by scan pc has Black Listed it.

Hey Mike!

You say your PC has blacklisted it?

Your PC cannot blacklist anything… do you mean it’s in the VST blacklist or do you have some kind of antivirus software that is blocking it? I had a problem updating my LX480 plugin earlier because my antivirus was being a d#ck about it…

Have you contacted Arturia support? They’re not always the quickest but i had to contact them on one occasion and they were fairly rapid and got me sorted very quickly… From memory i believe Jerome is the guy you need to contact.

It’s a shame as it’s a KILLER synth…

Late to the party, but mine’s working fine… My standalone is a 32bit exe but the .dll that Cubase uses is 64 bit, VST2.4.


Hi matjones & GargoyleStudio,

It is in the Cubase Blacklist but that’s not what I meant.

All install ok.
Software centre says they installed ok. Checked the install folders etc.
Have tried different install options.
Just the stand alone, just the vst 64bit, just the vst 32bit but none will load.
Even tried small rename of dll from Arp to Mrp but made no difference.

Also tried downloading install file from another PC.
Same issues.

This was the reply from Arturia:-


Hmm, this is weird.

Have you tried to uninstall and then run a cleaner app to clear all the possible remaining files ?

Have you tried to download another installer ? Like for example the previous version of the plugin ?


You can find the previous version by clicking on show archive on the concerned plugin section.

Best Regards


Have tried all but the cleaner app.

Strange that it wont load Stand alone or VST.
This is what I mean by Blacklisted as neither will load.
I would have expected the Stand alone to work as it Blue screened from Cubase so the file may have corrupted.

I do have Kaspersky internet security on the PC in Gaming mode.
It’s never caused any problems with other software to my knowledge.
Thanks again for your help.

Ok Mike thanks for the clarification.

This sounds to me very much like a windows registry error… hence Edouards’ suggestion…

are you familiar with the windows registry?

Hi matjones,

No not familiar with windows registry.

Arturia also suggested:-


CCleaner is a good free one




Arturia Technical Support


Hi Mike001,

Two ideas: perhaps its your graphics card, or maybe the default preset which is loaded when first opening the plugin is causing the crash.

a) I’d definitely check that you have the latest graphics drivers in any case, and make sure that everything else is up-to-date as well while you’re at it.

b) I don’t even know if there’s a default preset! But mine seems to start on the one which I selected last, so something is being stored somehow, some preferences somewhere. Anyway, for me the ARP is the plugin which most usually causes problems, i.e. white noise and crashes when changing patches. So, perhaps the preset it loads on startup is whta’s causing the problem…

Also, just to make sure the 64x dll isn’t corrupted, here’s the MD5 checksum for mine, you can validate your version by comparing. I used a program called SendToMD5 to calculate this: 591fa5877874714301ff011cb81359ee

I use CCleaner and I’ve never had a problem with it, I’d say its a very good tool. It can clean out space on your hard drive and also clean the registry of inconsistent items. I guess what Arturia are suggesting is to uninstall with their usual uninstaller, then delete traces of Arturia from everywhere on your PC, then run CCleaner, then re-install.


Hi matjones & GargoyleStudio,

Still the same after ccleaner.

Guess I will have to live with it till my next new DAW sometime in the next 18 months.
On the Grand scale of things it’s not a big problem just annoying.

Thanks for all your help.

Uninstal. Delete all Arp folders inside Arturia folders (search for Arturia folders, there are more then you think). Delete all Arp plugins in the vst folders. Start regedit. Search for Arturia keys. Delete all Arp keys from the Arturia keys. Install again.
Hope this helps!