8.5 trying to go online

hi there i run my music pc offline, how do i stop 8.5 trying to connect to the internet. thanks

Hi,

When Cubase tries to connect to the internet? Yes, Steinberg Hub does it, but… How does it border you?

ta for your reply ,“how does it border”, dont know what you mean ill take it you meant "bother ".
when i open cubase i can see that it is trying to connect to the internet, stuttering around and what not and so it is an unnecessary process for my offline pc plus i dont know if it is always trying to connect. maybe that is what has caused cubase to crash a couple of times ,losing me data and valuable time i cant retrieve. thanks
6.5 is far more stable at the moment but i have only being running the trial version of 8.5 for a couple of days so far ,so lets see. ta

Hi,

Sorry, I ment “bother”…

OK, so this is in the Steinberg Hub. You can switch the Steinberg Hub Off in Preferences > General > Use Hub.

I don’t expect, this is related to the crashes, you have. Of course, it would need some analyse of the crashes, but most probably, these are plug-ins related. Make sure, your plug-ins are up-to-date, please.

Unfortunately, this will remove the shortcuts to templates and recent projects aswell. I think a better way is to remove the “hubservice.bundle” file. On the Mac, select Cubase 8.5, right-click and choose “Show Package Contents”. Then dig down until you find it and drag it out to your desktop. (I don’t know where it is in Windows, but it’s there.)

This will only remove the left side of the Hub window (Internet related stuff), but retain the right side (templetes, etc.).

On Windows:
C:/Program Files/Steinberg/Cubase 8.5/Components/hubservice.dll

Unticking ‘Use Hub’ in the preferences should have the same effect as removing the hubservice. If it does not, it is not right.

Once de-selected in the Preferences, the Hub section (left) is not loaded, all you see is the Project Assistant, like in older Cubase versions up to 6.5. Attached a pic from my Mac after de-selecting ‘Use Hub’, the bundle file is still in the components folder.
Screen Shot 2016-10-17 at 13.21.27.jpg

thanks very much for tjhat info .
the crashes have happened when groove agent se4 has been open ,once while trying to save a preset and once while scrolling through sounds. also the mouse dissapeared behind the main cubase window while i had notepad pad open on the groove agent instrument track. thanks

ok thank you

thanks

oh! you were making a joke maybe , “border”. Brexit. :laughing:

Well Fabio, maybe this should be reported as a bug then, since it doesn’t work as intended? Unticking ‘Use Hub’ in the preferences bypasses the Hub/Project Assistant all together on start-up (I just checked a couple of seconds ago, just to be on the safe side).

You can still open the Project Assistant from File/New Project, but it does not show up during start-up. Tick “Use Hub” and remove “hubservice”, and it does show up during start-up (without the Internet side).

I wish that Steinberg would introduce an option, in preferences, to only show the Project Assistant, but not the Internet section, during start up.

This is an expected behaviour. Fabio was wrong (sorry…).

Oh, sorry, my fault, I didn’t understand your previous post correctly.
It does not show up automatically when starting Cubase, but it does when you select File -> Open Project or ctrl+N (cmd+N on Mac) indeed.

Sorry for the misunderstanding!

Nothing to be sorry about :slight_smile:

yes this did it , On Windows:
C:/Program Files/Steinberg/Cubase 8.5/Components/hubservice.dll
delete the hubservice.dll and leave “use hub” ticked in prefs thanks guys

If you want to avoid Steinbergu Hub, but you want to see an old “Cubase Open Document Options” dialog with the list of recent projects, hold down Ctrl/Cmd modifier key, while starting Cubase. This works even if Hub is enabled in the Preferences.