9.5.10 - Midi Filter Events - Program Change - Bug?

Hi everyone…

Since update to new Cubase version 9.5.10 it seems like the Midi Filter Events Preferences are buggy?
I have unticked the “Program Change” parameter in the preferences under MIDI,
and when I remind back to older versions, the Program Change midi CC was filtered or ignored - but now when the imported midi file has some program change cc in it, Cubase follows it and changes the program in the loaded VST.

?? Anyone else got that issue or can reproduce?

Thanks

Edit: changed chase to filter

Hi,

Do I understand you right, the Program Change is chased even if it’s disabled in Cubase 9.5.10?

Yes it seems so.
Maybe someone else can try it… but for me it is like you mentioned.

Hi,

I just tried this here on Mac. When I disable Program Changes from the Preferences > MIDI > Chase Events, the Program Change is not sent out, when I click anywhere in the project (and the Program Change event is used in the track, of course). So it works as expected, here.

Could you try in Cubase Safe Start Mode, please?

this is how my settings look like in Windows 10, Cubase 9.5.10:


and when I enter some program change cc in midi editor, and let it play - my vst (virus ti in my case but also happens in sylenth1) changes its program…

Cubase run in temporary safe mode with fresh preferences - same results.

here i recorded a short gif to see the misbehaviour:

https://imgur.com/a/e5ORK

Hi,

But the video, you posted, it’s not about Chase events. You probably want to filter Program Change out. The Chase event is about the sending data while stop, and clicking somewhere to the project. The last found MIDI messages are sent out, to make sure, you get the latest values.

If you want to filter the Program Change out, go to the Preferences > MIDI > MIDI Filter, and enable the Program Change MIDI Filter here on Playback side. Then the Program Change MIDI data will be ignored.

Thank you for the hint!
But its also not working:

https://imgur.com/a/XdLAm

OK, I was wrong, I’m sorry. The manual says:
“Activate any of these options to prevent the corresponding type of MIDI message from being thruput. It will, however, be recorded and played back normally.”

So you have to filter out by using MIDI Insert Transformer:
Filter Target:
Type is > Equal > Program Change

Action Target:

  • keep it empty -

Function:
Delete

Okay… but isnt it possible to filter these program changes out when dragging and dropping midi into Cubase?
I am not sure, I am using Cubase since V8 and this was never an issue till now…?! I am confused…

If you want to delete these messages, you can use the same pattern as you use in the Transformer. Just use it in the MIDI Logical Editor. Then all Program Change messages will be deleted.