9.5.20 - Taking ages to exit?

Is anyone else having issues with 9.5.20 taking absolute ages to exit? I have an i7 4960X with 64GB. Cubase has always been a -little- slow to close, but not as bad as it is right now. It’s not 100% consistent about it, but most of the time it’s taking several minutes to close. It does eventually close, however.

I did try a reinstall, as suggested by a thread I read somewhere. No joy. Same behaviour.

It’s not even project-specific. It happened with no project open at all. Start, quit, hang for a bit while it figures out how to close. Nothing in my Windows event logs from Cubase, so it’s not crashing…at least not with notice.

The only change I’ve made recently was upgrading to a 4k monitor, but I believe this pre-dates that change.

Anyone else having this?

Same here. Takes minutes to quit the app. I usually end up killing the process instead of waiting for it.

I’m afraid to say that I used have this problem with earlier versions but since version 9 (and with 9.5 too) the closing has been quick…so this isn’t typical any more.

It’s slow to close, but it doesn’t take ages. You just feel a bit of lag between hitting close and it closing. Hard to explain. But it doesn’t hang.
Is there a way to close out of the entire application? Everytime I hit x to close out it just closes the project and leaves the blank application page open, so I have to then close that as well.

Control-Q.

But your sig says you’re on 9.5.10, not 9.5.20. It wasn’t bad under 9.5.10. Occasionally it’d take a bit, but not this consistently.

Signature was wrong, sorry. No difference for me in exit times from 9.5.10 to 9.5.20.

Have you tried temporarily renaming your Prefs? If this is going to work you’ll need to close the program after renaming the Prefs, then re-open and see if closing is better the second time (and thereafter).

I’ve heard about issues when using Kontakt 5.7x needing a long time to save in Cubase 9.5? However I’m using it all the time and have not yet encountered this issue myself.

AFAIK the Kontakt issue affects all DAWs with VST support to some extent. It’s not new to Cubase 9.5.

Where’s the prefs file located, please?

The Prefences are stored within files within the following directory:

“C:\Users\USERNAMEr\AppData\Roaming\Steinberg\Cubase 9.5_64…”

You can temporarily move them somewhere else and Cubase will create a new default set. Make sure you know where you’ve moved them too!
The same thing can be accomplished by using Cubase’s Safe Start mode:
https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/safe-start-mode-resetting-the-cubase-preferences.html

Wow, thanks, had no idea.

Be aware that it won’t work if the virtual keyboard is up. In that case, Alt-K, Ctrl-Q.

You’re welcome. :slight_smile:

Thanks. Tied up with my day job right now, but may look at this tonight or over the weekend. Early next week, latest. (Really could use a weekend down, and this is too much like my day job.)

Can’t guarantee this will fix it but it has fixed some strange issues with me over the years. If it does you’ll then need to work out which Pref file it is causing the issue (easiest to do by bringing half back at a time). Good luck!

Same experience here. In fact, I thought that Cubase was simply hung on exit, so I never waited more than a minute or so before manually closing it by using the Task Manager. I’ll see now if it eventually closes after giving it some more time.

Its a bad idea to use the task manager to close Cubase, you will end up with corrupted preferences it’s just a matter of time.
Better to find out what is coursing it, it’s not Cubase itself, some plugin or a driver is responsible.

That sounds like good advice, but what choice do we have and how do we find the culprit? I didn’t buy the thing to test it. I need to get work done!

Okay, and of those having issues, how many use Avast Antivirus?

I’m starting to think that’s my issue.

I backed up my prefs, started Cubase again, and it took -forever- on the VST2 scans. Far too many were taking ages to start and be scanned. I had a bitch of a time rebooting my system, as well. In the end, I saw Avast Service taking a steady stream of CPU (again…they’ve introduced some bug into it that makes it just eat CPU randomly). Seems that was affecting a lot of software on my system. I don’t reboot as often as many people do, either.

After I tamed all that down, I tried starting/stopping Cubase again, and it was faster on startup, FAR faster scanning VSTs for the manager, and shuts down normally again. I then backed up the -new- preferences, restored my old ones, started and stopped Cubase, and it’s still faster. Read: back to normal.

I wonder if there wasn’t a coincidence whereby I didn’t notice Avast screwing with me, and that crossed over to after the Cubase update, and I got the wrong end of the stick assessing the situation.

I need to find an antivirus that doesn’t suck. Avast sucks now, AVG went to hell, McAfee and Norton/Symantec both suck. I don’t trust Kaspersky. You couldn’t pay me to install Panda. Maybe VIPRE…

I can’t swear that was my problem, but I can’t swear it wasn’t. It’s -a- data point.

NOD32 is very good. Give it a try.

https://www.eset.com/