9.5 Mac OS High Sierra Compatibility

Hi PG,

Is the current build of WL 9.5 compatible with the latest Mac OS High Sierra?

Thanks - DL

At this time, only OS X 10.11/macOS Sierra is listed as being compatible on the Steinberg website though I’ve heard several reports of people using Mac OS High Sierra without issue. I have Mac OS High Sierra on my laptop for light duty work and haven’t seen any issues, but my main iMac is still on macOS Sierra.

Waiting on the iMac Pro before moving to High Sierra on my main machine.

Trying not to be pedantic (but probably failing), this page is actually a little unclear: https://www.steinberg.net/en/products/wavelab/resources.html

Apple ref: https://support.apple.com/en-gb/HT201260:
10.11 = OS X El Capitan
10.12 = macOS Sierra

“10.11/10.12” or “OS X El Capitan/macOS Sierra” would be a little clearer.

Hi,

we will release an updated page for the product OS compatibility.

https://helpcenter.steinberg.de/hc/en-us/articles/115001813450-macOS-High-Sierra-Steinberg-Software-Compatibility