A 2 notation Bug?

Why does this happen? Is this normal? I want it to appear only once at the beginning of bar 11.
Page view:

Galley View:

2023-06-04 16-23-48_Sonate in B.dorico (1.4 MB)

I don’t know why it’s happening. If I create just those notes in a new Project, it condenses correctly.

As an experiment, I put a Condensing Change with a Reset under Manual Condensing at the first a2. This fixed the problem.

Thank you for your reply.

I still hope to have an answer as to why it happens and how to avoid it.

Dorico considers rests as boundaries between passages for condensing. In this case, each passage lasts only one note, and Dorico starts a new condensing after each rest, deciding a2 is a good option every time.

The strange thing is that I do exactly the same thing with clarinets, but I don’t have this problem.

It’s actually a bit more complicated than that. Dorico does normally use rests as the border betweeen passages for condensing, but it won’t do that for rests under a beam (or rests under a slur). So in this case the “a2” markings aren’t for the start of a new phrase, they’re for a “mid-phrase unison” - the phrase starts in b.9, and because the two bassoons are playing different notes there, the overall phrase isn’t a unison phrase. Thus each time within the phrase that the two bassoons do play in unison, it will be labelled.

There isn’t much you can do about this automatically, I’m afraid, but you can hide those extra labels by selecting them in Engrave mode and using the properties panel.

1 Like

English isn’t my native language, so maybe I missed something in your explanation.
Why is it that when I copy the notes from the bassoons and paste them into the clarinets, I don’t have the same problem? I also notice that the clarinets each have their own voice (inverted shafts), unlike the bassoons, which share the same shafts? Why is this?

here (in the video attached) my solution to the problem for the repeating a2. As @PjotrB and @Richard_Lanyon Richard said it has to do with the phrase (every rest creates a new phrase) and the midphrase unison. You can change it with a little trick shown in the video similar at what @Craig_F suggested (is much faster that write it all down :slight_smile:
Hope it helps


Thank you so much for taking the time to make a video. :+1:

1 Like

Hey! Have the same issue but looks like the video is down. Any help would be greatly appreciated.

If I remember rightly, the video was showing the approach suggested by @Craig_F in this thread:

I post the video again (that visualises the solution suggested by @Craig_F as Daniel correctly remembers :slight_smile: , this time with Google Drive :wink:
“a2” possible solution


Thank you so much!

This is so annoying. I’ve followed the video but it doesn’t solve the problem. When I uncheck “allow mid-phrase unisons,” instead of an a2 I get up stems and down stems. This looks messy. Worse, it’s only happening with my oboe and trombone lines. The bassoons look fine. Please help!

How can I fix this? Thanks in advance for your help.

SOLVED in this post.

1 Like

This video is no longer available. Do you still have it around?

1 Like