A bug or ? Moving files with WL open

I get through with an audio file and close it in WL. I then want to move the file to a different folder. I get a message that the file is still open in WL and cannot be moved. Is this a bug or is there some reason for this? If I want to move the file I have to close down WL and reopen it which seems the “long way around”. Am I missing a setting or is this a bug? I am on Windows 10 with all the latest updates. Thanks in advance…

This means the file is still open in WaveLab. This could be because part of it is in the clipboard or used eg. by a montage.
The simplest way to “solve” this, is to close and repen WaveLab.

Thanks for the quick reply. That is what I was doing but though maybe it was something I did not have setup correctly. Be safe and thanks for making Wavelab what it is…

This is becoming a BIG problem. I want to trash certain audio files but I have to close and reopen WL everytime I want to trash an audio file. Is there no other way to do this without having to close WL???

Thanks in advance.

Here is another topic with the same issue, have a first look here:

The easiest way may still be closing Wavelab and then deleting your files.
But if you insist on keeping Wavelab open, you could at least rename your unwanted files to pre-sort them. Just open them in the audio editor, go to File > Rename… (or just hit [F2]) and add any characters you want to the name to mark it for deletion (if a file is currently part in an opened montage, the montage will be updated to the new name, a montage opened later will not find the renamed file automatically). But this is file by file only, and I’m not sure if there is some kind of batch-renamer.

Still, after a quick test in Wavelab Pro 11.1.10 there seems to be something odd (I’m also on Windows 10 Pro)… here is what I did and found:
1.) I just made a simple duplicate (copy) of a WAV file via the Windows Explorer.
2.) I opened both the WAV and the WAV-duplicate in Wavelab (I restarted WL before for a clean setup, no plugins loaded), made a selection in the duplicate file and copied the audio samples.
3.) I then tried to delete the duplicate via File > Delete (or shortcut [Alt] + [Shift] + [Backspace]) - as expected, Wavelab wouldn’t delete the file, it just closed the duplicate file.
4.) So I switched to the other file, selected and copied some audio samples from there, opened the duplicate file again and tried to delete it again - without success…
As far as I recognized so far, Wavelab has its own clipboard for audio content and can hold 1 copied “object” at a time (audio samples, one or several clips in a montage, … maybe other things too), right? So my guess in relation to my test would have been, that as soon as I copied some samples from the original file, Wavelab should have released the duplicate file and it should allow me to delete it). No other manipulations were made with the files, so there are no additional entries in the History window besides “Initial Version”. The same thing happened with a quick test in Wavelab 10.0.70 too.

PG, maybe you can explain or look further into this?

I’d like to add that this file locking happens all the time and is quite irritating. Let go of my Eggo!

I realize that these file locks happen in Windows for various reasons, but I don’t think that I have parts of the file in my clipboard. And the files are definitely closed and no longer in use. And worse, I often get a crash when I close Wavelab to try to clear the file lock. Perhaps, when a file is removed from a project or at when a project is completely closed, Wavelab could affirmatively flush handles and release files that are no longer in use?


Are you using built-in File Selector/Browser in WaveLab or OS !?
Check File > Global settings maybe this can solve the problem…

regards S-EH

Yes, this is the case. Since something can be copied multiple times, there is no reason to clear the clipboard after using it (copying from it).

Yes, that makes sense. But I would expect, that a new object copied (other source file) to the clipboard would basically override the current/old one, so that Wavelab would no longer have any handles linked to the previous copied file/objects (as long it is indeed currently not loaded within a montage or opened otherwise).

Whatever the reason it is really messing with my workflow. Is this something that cannot be “fixed” or modified??? When I close a file in other DAWs I can then delete it without closing down the DAW. It seems that one should have the option to be able to delete files with WL still open. I am not a programmer so maybe this is something that is impossible or is somehow tied to the OS. Thanks for any feedback.


Not sure what you mean by this:

Are you using built-in File Selector/Browser in WaveLab or OS !?
Check File > Global settings maybe this can solve the problem…



I simply mean perhaps the ““File Selector”” have something
to do with “keeping file(s) in memory” and is different
in OS Windows or OSX, from the built-in inside WaveLab !?

regards S-EH

Here is an example / data point for y’all:

  1. Start new montage (File > New)
  2. Drag + drop 4 files from Windows Explorer into the montage
  3. Do whatever you do when you do whatever you do…
  4. From clip #2 and clip #4 - Render > Selected Audio Range > mp3s – make a couple of 30-second samples.
  5. Open and play back the mp3s within the montage (not sure if this is important)
  6. Finish up, save montage and close all files and the project tab.
  7. Go to Windows explorer and delete all of to clip files

Clip files #2 and #4 cannot be deleted because they are still in use by Wavelab. They remain in use until Wavelab is closed.

(I forgot to check whether I could delete the mp3s)