A chord is displayed twice on the staff which has an instrument change

Hello,

A chord is displayed twice on the staff which has an instrument change as follows:


I am attaching the project file as well:
chord displayed twice.dorico.zip (605 KB)
How can I resolve this?

Select one of the two chords and hide it in the properties panel?

Hiding one of them hides all of them, regretfully.

Select more carefully…

OK, what I experience is as follows:
https://www.dropbox.com/s/ntbcn005in5t4to/Screen%20Recording%202019-03-07%20at%208.49.19%20AM.mov?dl=0

Hiding the chord below hides only itself, but hiding the chord above hides both of them.
Moreover, a further duplicated display (Cm7) appears in the next bar while hiding Dsus4.

Hiding one of duplicated display could be a user-side provisory resolution.
Could it be fixed by developer in future version of Dorico?
It seems to be a limitation (or a bug) of instrument change.

What if you use the Layout Option to show chord symbols above the top of the system? (Layout Options > make sure you select the correct layout on the right side > Staves and Systems > Chord Symbols). Does that fix it?

Or does this problem with duplicated chord symbols affect the score as well as the part?
I have to admit, this is a problem I’ve never seen before. I’m not sure if there’s something weird in your file or if this is a more general problem.

I already selected “show chord symbols above the top of the system”.

The problem affects the score and the part.

I experienced this phenomenon two times at least.

I think this could be a general problem because I removed lots of bars before/after the bars on the system to submit the project file here.

Another thought, prko. I don’t have time to try this just now but I notice that (for the purposes of chord symbols) one of the instruments is a Rhythm instrument (synth) and the other is not a rhythm instrument (harp). What happens if you make both instruments rhythm instruments? You could change the harp to a piano, for example.

Changing harp to piano does not resolve the problem, regretfully. :cry:

I’m just puzzled that I’ve not seen this problem before, because, frankly, I’ve seen most things before! Hopefully someone from the development team will be able to shed some light on what’s going on here.

I’m not sure exactly why at this point, and I will ask the team to take a look when they get a chance, but something about the fact that the chord symbols are overlapping the transitions between instruments at bar 5 and bar 9 are causing the chord symbols that coincide with the instrument transitions to be drawn twice. I’ve never seen this before so at the moment I’m at a loss to explain it, but we’ll look into it some more as soon as we can.

Thank you for your time and working!

Prko, I did what Leo suggested, and it seems to have worked. I went into Layout Mode, selected Layout Options, made sure synth/harp was selected on the right side, and selected Show Chord Symbols above the top of the system. Is this what you’re wanting?

Also, it only seems to happen (now) in the “All Instruments” layout - not the part, and not the Full Score. So perhaps something’s not right with that particular layout?

I tested it again.

@ pianoleo
In my previous try, I can remember what was not correct. Sorry!

@ jr88keys
The problem is resolved for the specific part.

However, the problem remains in the score…
Displaying chords only on the top of the system seems not to be correct.
It would be nice to find a way that selecting ‘Above specific player’s staves’ in Chord Symbols in Stave and System in Layout Options also displays the chord only one in the systems which have instrument change.