A few performance questions

I’m running Cubase 8 pro in Windows 7 64bit.
Cubase 7.5 worked quite well, With high latencies I never really experienced any problems.
I also never used Asio Guard.
Now with cubase 8 it seems that the performance meter reaches it’s limits earlier than expected.
This is with Asio guard off.
When I want to turn it on Cubase says that I should lower the latency but wouldn’t this make the glitches worse?
Would you recommend me to use asio guard or leave it off?
I would really like to see some improvement here instead of a decline in efficiency.
Before using Cubase 8 I also never used Aero, could this also be hogging my CPU a bit of would the difference be minimal?
Other than that I’m loving Cubase 8 a lot!

i have very similar questions in my other thread.
With using VST2 64bit, and lots of them, EWQL and XFer and what not, i have a degradation of performance compared to 7.5 (using around 60 channels 7.5 wasnt stuttering, 8 is periodically stuttering peaking off CPU). (Not to mention that 5.0 was even much faster and lighter on CPU than 7.5, but that’s another story :slight_smile:)
I didn’t mess around with the Asio guard. I expected to have better perfromance without any messing with settings on default settings. I’d really like to see some advice as well. I’m using 7.5 till i really see a perf improvement on 8 Pro.

The new audio-engine deals with a lot lower block-sizes. If you set the latency high above this block-sizes, that would make ASIO-Guard simply useless.

It’s a new set of things to get our heads around. I think everyone’s mileage will vary depending on the plugins they use, their project size, the soundcard, how they work etc.

The secret is just to try things out - you can’t damage anything after all. What you’re looking for is the performance when switching tracks, along with the input monitoring. This is the real call on your soundcard’s resources, where you’re suddenly switching from a nice preloaded buffered performance to something as close to real time as possible. I made the initial mistake of thinking I was getting stunning peformance with a buffer set at 48 - set asioguard to high and you might find the same apparently remarkable results. But it’s a bit of an illusion - switch to a live instrument and suddenly the picture changes spectacularly.

Overall I’m finding performance with asioguard to be better than C7 without. That’s the good news. The bad news is that this isn’t universal. I use VE Pro with a large orchestral template - push that asioguard up and your regular buffer down and the whole thing goes into spasm as you switch tracks. That’s an issue specific to VE Pro, although every plugin does get a call on resources when switched to live.

So get experimenting. It’s an interesting time this - I think the asioguard technology is a great idea and this implementation works massively better than asioguard 1. Might take a while to iron out all the kinks though.

(nb - isssues thread submitted re VE Pro here - http://www.steinberg.net/forums/viewtopic.php?f=230&t=70250&e=0 and vsl here - https://www.vsl.co.at/community/posts/t38487-VE-Pro-audio-muting-when-switching-tracks-in-Cubase-Pro-8 )

The DPC Latency Checker by THESYCON is a good tool for checking your audio/video capabilities of your PC

http://www.thesycon.de/eng/latency_check.shtml

As reference, my audio production i7 host floats between 58us and 105us with Cubase Pro 8 running.
During the test, If I open a few videos in separate windows and a couple of youtubes in my browsers, I still peak up to about 500us

If you see large spikes in the scrolling graph you have a problem with your system design that needs to be addressed by your computer service professional.

I’still curious about this…
I lowered the latency and turned on Asio guard.
The performance does seem a little more stable (less spikes) however the performance bar was still a bit high I think.
How has this been working out for you guys?
I read somewhere that 512 as latency is a sweet spot for Asioguard.

Perhaps try disabling ASIO Guard INDEPENDENTLY for each plug-in. You may be able to identify one of them that doesn’t play well with ASIO Guard. You can do this on the Plug-In Information screen at the bottom when you select the individual plug-ins.

I had serious performance issues when I installed Cubase 8 Pro alongside Cubase 7.5 (I had a large project that worked perfectly in 7.5 but couldn’t play at all in 8, no matter what buffer size). I did a complete wipe and re-install of windows and all my software and now it’s, in my opinion, even better than 7.5 was. It may just have been some settings carried over from my install of 7.5 that affected things, but I typically like to start fresh on any major upgrade to Cubase.

Man that’s a lot of work… maybe something to try though in the near future.
I wouldn’t say my issues are really serious so I’ll keep watch on that performance meter for a while…

“Details on ASIO Guard in Cubase and Nuendo”:
https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/details-on-asio-guard-in-cubase-and-nuendo.html

Ok, so I’ve done a bit more experimentation.
It turns out that I was using Asioguard in Cubase 7.5 but I just didn’t realise.
I opened the same project in Cubase 7.5 as in Cubase 8 to compare the CPU meter.
The results were quite close (with Asioguard enabled in both 7.5 and 8).
In Cubase 8 I have it set to the maximum setting with 2048 as latency (can’t set it higher).
In Cubase 7.5 I was used to setting the latency quite high, mostly 4096…
Anyway, the green meter is about the same in both versions but a little bit higher overall in Cubase 8 unfortunately.
The difference isn’t huge but I was still expecting Cubase 8 to be a little more efficient.
However, the blue meter was almost at 0 the whole time with Cubase 8 whereas with 7.5 it was floating around at halfway during the whole song.
I wonder what this means…
I still have hope for a better overall performance with Cubase 8 so any tips would still be helpfull!
Thanks!

ps: I am using windows 7 64bit, I am using my Fractal Audio Axe FX II as my usb interface set to 48khz and 24bit at all times.