A little routing issue when creating an audio track…

(I just marked this with the issue tag, as a cubase-all-versions one is still missing…)

Hi, all

I often have a little routing issue with Cubase Pro when creating an audio track, and this, since a long while, so it’s not version dependent. It’s not dramatic and the workaround (described further) is easy, but still… Here it is.

I recently wanted to create an audio track to record a stereo output of Emulator X3 VSTi (my beloved multioutputs sampler), as I often do. For this, I both have it set as an instrument rack one and have a dummy bus (_render) to both receive Emulator X audio outputs signal and dispatch it to any audio track set as record enable for this purpose. In use, it looks like this (note that its output routing is set to No bus) :

The issue is the following : when attempting to create the audio track, the Audio Inputs dropdown list is this one :

As shown, no _render bus available, so I’m forced to choose another one to actually create the needed track. BUT, once it is created, I have this, in the dropdown list of the inspector Input routing setting : the _render bus magically appears and is usable again.

Added to this, if I set the output routing of the _render bus in the Audio Connections > Groups panel as Main out, it then becomes also available in the Add track|Audio window.

So, it seems that any group/bus with No bus as Output routing becomes unavailable in the Add track|Audio window, as if it no longer was a legitimate audio source. Consequence : I always have to go through a two stages process to configure an audio track which will record a ‘dummy’ bus (which doesn’t send a duplicated audio signal to the Main Out).

From which, my question is : how comes that any bus/group set with a No Bus output routing can’t be used as a valid input source in the Add track|Audio window ?

Thanks in advance !

System used : Windows Pro 10 (22H2) / RME Fireface UCX (USB) / Cubase Pro 12.0.60.

Confirmed, PC 12.0.60

Group channels that are routed to “No bus” do not appear as a choice for the input when creating a track.


Thanks ! :slightly_smiling_face:

Same with the Sidechain inputs, sometimes they don’t appear in the list if they are already in use somewhere else. That’s driving me crazy for real.

Yep, but in this case, the _render bus isn’t even used somewhere else… So, I think that this is a bug, actually : any bus/group, set with No bus as output routing, becomes invisible in the Add track|Audio window… :face_with_raised_eyebrow: