A plea for help to save my business regarding upgrades (mac specific)

So, my music teaching business just got locked down. And I want to teach via Skype. BUT…

I’m running an old version of Cubase 9.0.1, on a mac running El Capitan 10.11.6. (Why? because I got sick of upgrades that predicated my favourite plugins. I’ve been a registered user since V.1 & even earlier - I used Pro24.)

So I need to upgrade my OS to run Skype. Will I still be able to run Cubase V9? Can’t afford an upgrade :frowning: Thanks in anticipation.

What OS are you upgrading to?

Cubase 9 is qualified to run on 10.11 and 10.12 OS https://www.steinberg.net/index.php?id=14733&L=1

So you can only upgrade your os to 10.12 accord to Steinberg.

SKYPE FOR MAC:
https://support.skype.com/en/faq/fa10328/what-are-the-system-requirements-for-skype
Mac
Version
Skype on Mac requires Mac OS X 10.10 or higher
Processor
At least 1 GHz Intel processor (Core 2 Duo)
RAM
At least 1 GB
Additional software
The latest version of QuickTime