"A serious problem has occurred" when using EastWest Play

Hello, I am having a bit of a long issue - I sent this same message over to EastWest as I believe it’s an issue on their end but maybe you guys can help me out.

I use Cubase 9.5 and I am on the very latest version. (before reinstall I even went as far as to update to the very latest version)

Abruptly today while I am 3/4 the way through exporting master files for an album for my client, Play (play is the eastwest Virtual Instrument which houses all of their sounds in the creative cloud package) has decided to give me an error which renders the entire application useless. Whenever I try to load a project that used Play or create a new project and add an instance of Play, I get the error:

"A serious problem has occurred: Please try to save your project under another name and then restart Cubase9.5.exe. If this problem persists please contact Steinberg Technical Support with a description of what you do to create this problem, and the created file C:\Users\scooter\Documents\Steinberg\CrashDumps\Cubase9.5.30.192 64bit 2018.6.22 3.39.dmp.

Click ‘OK’ to be informed about further occurences of serious problems, or ‘Cancel’ to suppress these warnings in case of cascading warnings!"

There may be a typo or two in there, sorry.

I have completely wiped EW installation center and Play from my computer and reinstalled from scratch. I cleared the registry when I did so. It should have been a fresh install and have worked upon launch after the re installation. Same exact error.

I have noticed that the VST2.4 does not show up in Cubase. The VST3 is the only plugin that will actually be recognized by Cubase, and that is the one which is giving me this error I believe.

This is causing me a huge headache (I think I mucked around with this for about three hours) I would be extremely grateful if someone could give me some help

Cubase 64bit 2018.6.22 3.39.dmp (1.32 MB)

Hi and welcome,

The crash is in EastWest Play plug-in. Please contact the vendor.

Thank you! I have contacted them as well

good luck… Play is the ultimate junk as far as bugs and instability… had so many issues had to stop my sub… that was with pro tools at the time… sorry to read it’s just as bad with Cubase…

I am using Play ‘play_VST_x64.dll’, version - no problems.

i never used 4, i entered at 5 and then at 6… then cancelled… i had NOTHING but problems… the joke is they actually finally confirmed everything i had reported… There was a timing issue where the AAX was not receiving transport and midi timing correctly, as well as crashes just browsing certain patches…

10 years now and I can’t remember a time when Kontakt crashed.

Many of the SOUNDS in play were fantastically usable… that’s the only part I miss!

I’m currently having the exact same problem in Cubase 7.5. I’ve tried reinstalling both Cubase and Play completely from scratch but still having no luck.
I don’t suppose you’ve found a fix for this? I am also going to contact EastWest about it as I’m pretty sure it’s their issue.
Thanks in advance!