About TC Electronic plugins not working on Cubase 9? (Fixed)

To be honest I’m not overly bothered about most of the plug-ins on my TC Electronic Compact, except for the “Access Virus”. Seeing as the TC plug-ins now show up in the Cubase Blacklist I suspect it’s to do with the the 64 bit bridge used by TC Electronic.

But in My opinion the Access Virus is still the best of the best and, for me, has been used in every project, for years, and if this is it’s end of the line I’m going to really miss it.

Unless of course someone knows something about this that I don’t? As far as I know Cubase 9 is done with 32 bit plugs altogether and no longer support 64 bit bridges of any kind. But, I’m not absolutely sure about that. I doubt they will turn it into a native vsti but if they did I, for one, would happily but it again.

Anyone out there know anything? Work around ideas? Theories? Desperate I know, but worth a try.

Thanks peeps and happy holiday :nerd:

Just a thought, but anyone know anything about rewire? I think reaper still supports 32 bit plug-ins or at least 32 to 64 bit bridges, does it not?

That would good if that would work. Reaper being relatively inexpensive an all.

No need to all shout at once :slight_smile:

But relax. I’m watching a youtube video on rewiring Live into Cubase, which could be expensive but. I see no reason why It’s not the same with Reaper

Jbridge works for my very old 32 VSTi and plugs.

In Cubase 9? Are you sure? Because I’ve heard that C9 doesn’t recognise Jbridge.

I believe TC Electronic PowerCore uses a Jbridge variation and it doesn’t work in Cubase 9.

Powercore and Jbridge work in C9, I didnt even update Jbridge.

No problems with my Poco plugins, Cubase Pro 9.01 and jbridge 1.75.

All Powercore plugs working well for me too, I think I am using Jbridge 1.4, (Windows 7)

All my PoCo plugs are all blacklisted in C9 and do not show up in the plug-in list, but work fine in C 8.5.

So if they work Ok for others, the question is, why?

Have you tried to un-blacklist them ?

Are you not using the PowerCore 64 bit installer 4.4.3? I’m a little confused now. Are you saying you installed the PoCo plug-ins with the 32 bit installer and then wrapped them with Jbridge 1.75. Because if that’s the case then that’s what I have to do, right?

How do I do that?

Edit: Mmmm… delete the blacklist xml, perhaps?

Dunno. According to the plug-in manager they’re blacklisted because they’re 32 bit plug-ins, which we know but TC Electronic supply a 64 bit installer that somehow Jbridges them.

I’m confused :open_mouth:

on the blacklist page you ca reactive them.

That’s from within Cubase, yeah? I couldn’t see anyway to do that from the plug-in manager but I’ll take another look now.

Thanks for taking the time to help by the way. Much appreciated for sure

Nope. Unless I’m missing something obvious there doesn’t appear to be any way to reactive blacklisted plug-ins from within the plug-in manager. Which states they are blacklisted because they are 32 bit plug-ins, which are no longer supported.

And yet, others seem to have them working. I’m at a loss!

ok, you need to bridge them to 64 bit with jbridge first. If the go to the blacklist again afterwards (which I doubt, none of my bridged plugins did) you can re-activaze them.
I also never heard that poco uses some kind of jbridge. I think you have used the normal 32 bit plugins so far…these won’t work in cubase 9 without jbridge

Thanks for taking the trouble. I’m looking into it. There are 2 installers for PowerCore 4.4.3, one described as 32 bit and the other as 64 bit. The latter, which as been working fine in Cubase up until vr 9 and which I am given to believe uses some variation of Jbridge, is what I have installed. I think you are saying your PoCo plug-ins are installed with the former installer and then bridged by you with Jbridge, which is different.

From within the Cubase plug-in manager/blacklisted, all individual PoCo plug-ins are shown as 32 bit, so cannot be reactivated. However, there is one plug-in in that list called “TC Electronic\PowerCore\WsfCoinstaller01009.dll” which is shown as 64 bit. This one can be reactivated but the reactivation fails.

This link explains more about blacklisted plug-ins in Cubase 9: https://helpcenter.steinberg.de/hc/en-us/articles/207348390-Plug-in-Sentinel-for-Cubase-9

If others have it working then there is no reason why I shouldn’t. I just have to get to the bottom of what’s going on here.

But again, thanks.

I think the 64bit installer is only for the 64bit drivers for the hardware.
The plugins are 32 bit.At least that was the case about 15 months ago when i sold my last powercore…

and the others have it only working, because they bridged the plugins with jbridge.

In Cubase 8.5 they worked for you because Cubase bridget them internally

https://dynax.at/pcore-x64- are 64Bit driver and software. But the plugins themselves are only 32Bit. They didn’t work in Cubase 9 without using jbridge.

Ah! Brilliant thanks. I haven’t used Jbridge since before my last PC build but I’ve just dug it out. I have version 1.5 and I’ve just downloaded the update for v 1.75. So, I’m about to get on with it…

Thanks everyone for your help. very much appreciated.

I’ll keep y’all updated on how it works out or if there are any set backs.