Accidentals in staff-attached text?

Is it possible to input accidentals in staff-atached text? Couldn’t find a way yet. Would be nice to be able to show original harp pedal markings text.
Thanks!

Sure, you can use Bravura text. Or MusGlyphs-Text is even easier!

@dankreider : … but how do I enter an accidental sign?

With MusGlyphs-Text? Just @n, @b, or @# for a natural, flat, or sharp.

No, I meant with Bravura text. When opening Staff-attached text with ‘Shift-X’, there is an option to choose Bravura text, but no option to enter an accidental.

For that, you need to use the Unicode combinations, or copy-paste from here.

Ah, I’ll try that. Thanks!

@dankreider: I’m sorry to have to get back to your earlierreply. I tried to find the unicode for a natural but couldn’t find it. As to the SMuFL: I’m new to that. What do I copy and paste, or how do I use the code, for instance U+E261 for natural?

To be honest, I find Unicode very confusing. That’s why I created MusGlyphs. I haven’t used Unicode, or copy-paste for glyphs, in quite some time.

1 Like

Pasting/typing Unicode depends on your operating system. On Mac there’s a Unicode keyboard layout - you just hold down Alt/Opt and type the numbers/letters. On Windows there are various third-party programs to help, but off the top of my head there’s no easy native way.

For pasting from the SMuFL website, you select the glyph itself - that’s the musical symbol graphic, not the code - copy, then switch to Dorico and paste into the Shift-X popover. With the character still highlighted in the popover, select Music Text from the character style dropdown towards the top left corner of the text editing toolbar. Until you do so the pasted character may well appear as a rectangle or a completely different character.

Thanks, both. On this page: Browse the glyphs | SMuFL , the ‘natural’ glyph cannot be selected nor copied (I use Win 10), only saved as *png.

Try this page instead: Browse the glyphs | SMuFL

Hi. I am on mac and find it quite easy to use the unicode code for that. 266D, E or F for the different accidentals IIRC. It’s just a matter of adding the hexunicode keyboard in the general preferences of your macos system and keeping the alt key pressed while typing the four digits. On Win YMMV.

Thanks. I tried to use the page you mention. When I copy the natural glyph symbol from that page, it will past as the number ‘2’. ??

I use PopChar, which is a utility for both Mac and Windows, that lets you browse all the glyphs in a font and insert them into the current text field.

The font manager FontExplorerX will also let you browse and copy any glyph.

It sounds as though maybe you haven’t correctly set the character style dropdown in the top left corner of the text editing toolbar. You can set that just before you paste rather than just after, if that’s easier.

I finally managed to make it work, Thanks! Odd however, that this feature isn’t implemented in Dorico in a simpler way.