Activating Dorico 4 Upgrade from 3.5

I’ve been going in circles trying to access my Dorico 4 upgrade since downloading and installing it on my Windows 10 PC. I’ve inputted the Activation Code and updated my licence for Dorico 3.5. However, whenever I click on the Dorico 4 icon, a dialogue box headed ‘Launching Steinberg Activation Manager’ opens up and nothing happens. I then click on the ‘Relaunch’ button and still nothing happens. I’ve tried to request a support ticket under Licensing and Activation. Having inputted my name on the form, when I click on the ‘Continue’ button I’m taken to the Home page for Dorico - a dead end. I’ve run out of ideas on what to do next.

As a long-time Sibelius user, I’ve been keen to wean myself off Avid and make the long-promised, final switch to Dorico. I’ve not used Dorico for quite a while now and found the entire process of downloading, installing and activating the upgrade to Dorico 4 just about the most clunky, non-intuitive, frustrating process imaginable.

Are you able to run the Steinberg Activation Manager on its own, e.g. can you launch it from the Start menu instead of by running Dorico? Are you running the most recent version of SAM (1.3.1)?

I have the latest version 1.3.1. I have tried running it from the Start menu but that takes me to the .exe file and all that happens is it tries to reinstall SAM. The app is certainly there - all 62.9 Mb.

If you navigate to the installation folder manually in Windows Explorer and try double-clicking the executable, what happens? (I don’t have a Windows machine here to hand, but I believe it’s C:\Program Files\Steinberg\Activation Manager.)

Hello Daniel, Sorry to intrude on your Sunday. I’ve found it under C:\Program Files\Steinberg\Activation Manager. When I double- click on SteinbergActivationManager.exe nothing happens.

Could you see whether you have a directory %appdata%\Steinberg\Activation Manager - if so, could you zip it up and post it here?

Hello Richard (apologies for not acknowledging you before) I’ve found, under Activation Manager, a Data folder, a Logs folder and a settings JSON File. They’re all quite small. I’m not familiar with creating zip files. Would it help if I just posed the contents of the folders along with the JSON file?

If you select the %appdata%\Steinberg\Activation Manager directory in Windows Explorer and right-click, that will give you an option to “Send To”, and one of the sub-options of that will create a zipfile:

image

Unless you’re on Windows 11, in which case “Compress to Zip file” is on the top-level right-click menu.

Thanks - you learn something every day ,
Activation Manager.zip (13.1 KB)

Well, I can indeed see that SAM itself isn’t launching when you run Dorico, though it looks like it did launch on the very first attempt (at 17:08 today). That makes me think that maybe the SAM process has hung when shutting down on that occasion, which is preventing it from being restarted. If you look in Task Manager, is there a Steinberg Activation Manager process listed anywhere in there? If so, can you end that task. Alternatively, if you don’t fancy poking around in Task Manager, can you reboot your PC and try running Steinberg Activation Manager again?

No sign of SAM in Task Manager. Is this an uninstall/reinstall issue?

Correction - I’ve found multiple SAM entries under Background Processes - all at 0%. I’ve just terminated all of them

I would try rebooting first (if you haven’t already). The fact that SAM seemingly did run on one occasion makes me think the installation is basically OK, and the background process that does all the hard work (the Steinberg License Engine) is also running OK.

Right - will do and come back to you once that’s done.

Another possibility is that the SAM window is somehow being created off the screen. I’ve had that sort of thing happen with various apps on WIndows - a bit of googling will turn up a lot of pages like this one https://www.technipages.com/bring-off-screen-window-back-onto-screen

I’ve restarted my PC. Clicked on the Dorico 4 icon on my Desktop and got exactly the same dialogue box stating “No License Found”. A second dialogue box followed “Launching SAM”. As before, nothing happened. I clicked on the Relaunch button but still nothing happened.

Ah, hang on. It might be that ‘dialogue box stating “No License Found”’ is the Steinberg Activation Manager, unless I’m getting confused. If so it should provide instructions on what to do next, e.g. to Sign In, or to activate your licenses. Could you post a screenshot of the dialog here?

I followed the instructions on this several hours ago, as set out in one of the Support Articles.

I entered my Download Access Code, then entered an Activation Code to update my licence for Dorico 3.5.

Richard - thanks for your efforts and help. I’ll be retiring now so can we pick this up tomorrow?

Right, that dialog that says “No License Found” is indeed SAM, so at least we know that is working. If you click on “Dismiss” in that dialog, it should then show you a list of all the licenses that exist for your account in the new Steinberg Licensing system. Could you post a screenshot of that? If that is completely empty, then it suggests your problem happened in the earlier steps where the v3.5 license was upgraded - that process is described here.

I understand that this whole process is rather painful. Because of the shift in licensing technologies from v3.5 to v4 it does mean that an upgrade requires both technologies at some point, which is fiddly and error-prone.

Back again. I followed the dialogue box instruction to launch Steinberg Download Assistant. When this opened, it showed Dorico 4 and the list of Downloads - all four elements had been downloaded and installed. I then went to enter my Download Access Code, as I’d done before, and another dialogue box opened in which I cut and pasted the Access Code. A further grey dialogue box appeared asking if I wished to upgrade my license. When I clicked on upgrade, a new box appeared headed ‘No License to Upgrade Selectable’.

When I first went through the above sequence yesterday, I chose the USB e-licenser to upgrade as this was associated with Dorico 3.5 and that seemed to work. The Soft-eLicenser below it was associated with Wavelab (an early freebie from Dorico), so I ignored


that.

I do have the original USB dongle plugged into my PC and it’s been there ever since I first downloaded Dorico so I’ve no idea why the dialogue box states: “Please connect a USB-eLicenser which contains an appropriate license to upgrade your computer”. I only have the one USB dongle.