Activation manager log in fail

I have installed Cubase Pro 12 perfectly. The problem is not getting past the activation manager. My internet connection is perfect for viewing everything and writing comments here. However, to log in for activation, only ‘try again’ is repeated as shown in the picture. I tried to install and try many types of explorer, turn off the firewall, and also try a lot by allowing pop-up windows, but the result is always the same.
I think I’m going crazy now. The work to be done is piled up like a mountain.
Please ask for help asap so it can be resolved.


Hi,

Does your browser allowed pop-ups?

yes.i do

Let’s keep this in one topic.

Your Steinberg Activation Manager is outdated. The latest version is 1.4.0. It should be updated automatically when you run the Steinberg Download Assistant.

Have you tried using a different DNS server, such as 8.8.8.8 or 1.1.1.1 ?

The version of the photo was just captured because it was in the same situation as me. It was the same even if I deleted the manager and installed the latest version. It’s so frustrating.

I had the same issues and still I cannot do offline activation. I found out that it has to do something with my VPN but still don’t know a real solution.

What can you try as a solution to this problem? I don’t have another version of Cubase. must be resolved

Is your vpn blocking me?

I don’t know if you have a vpn but if not try to install one and check out of this change things