Add fades on playback to remove clicks when starting or stopping on a non zero-crossing point

Is that possible to implement an automatic fading of the audio when you press Play, Stop, or when you move the Cursor during playback ?
The reason for this is that it would finally remove once and for all the clicks that occur when we start and stop playback at a non-zero crossing point.
Honestly, I don’t think that would take a lot of effort to add a few lines of code to do that.
It has been requested for a very long time already.

Read the manual. It’s a very complex DAW with features you may or may not have heard of before. Reading the manual will not answer every question, but it will answer most questions you’re going to get a bunch of opinions on in the forum. If everybody read the manual we’d have a much more educated forum.

I’m well aware of the Snap to Zero-Crossing function, which only works with the range selection, split and warp tools…
Just wondering if you are mocking me or not.

Read the manual

I don’t think the OP is asking about event fades. The question is about fading in the playback engine from wherever the cursor is placed.

I haven’t noticed, or at least haven’t been bothered by, any pops/clicks when hitting play. This isn’t a helpful comment to the OP, but I think I understand the request.

1 Like

I’m requesting a feature where the audio makes a fade in when you press play and a fade out when you press stop, to prevents the clicks it makes when you start and stop playing from the middle of an audio clip.

@kelp You posted when I was typing my reply, now the order is confusing :laughing:

Yes you got it.
It all depends on the material, you won’t hear it that much on a full on metal track, but on simple waveforms like bass lines the clicks are much more noticable.
Anyways, since the clicks are not louder than the actual audio that’s not really a major issue.
I’ve read Ableton users saying that Live doesn’t make clicks on start stop and feels much smoother compared to other daws.

I second this request, and it sure does make Cubase feel a little unpolished. If people are worried about playback accuracy, just make it an optional feature. Luckily this is “only” an issue during interactive playback (those clicks don’t make it into exported audio files), but it still presents a less-than-professional image, esp. with attentive clients in the studio, hearing (and asking about!) what that weird click/pop noise was…

Maybe try adjusting the buffer size

I don’t think it’s a buffer size issue, but thanks for the suggestion! I’ve played around with buffer sizes a lot, trying to dial it into a point where latency isn’t so large that it presents an issue when recording live performers, yet having it large enough to prevent glitches. I think I’ve found a good balance, and I’m pretty sure this is due to the playhead not being able to snap to zero crossings across many tracks, hence the (good) suggestion by @Louis_R to add an optional (very short) fade-in feature.

Maybe try adjusting the buffer size

This has nothing to do with the buffer size, it’s a completely normal behavior. Try rendering a sinus wave as audio file (not VSTi) and then hit play somewhere in the middle of it (at a non zero-crossing point). You’ll get the same result, which is a quick pop when hitting play.

I notice this especially on my bass tracks, my guitar tracks are fine though. Probably because it’s more audible on lower frequencies?

Other DAWs like Reaper, Pro Tools, … have a setting to “mini-fade-in” on playback. StudioOne even does this per default. I agree with @Louis_R that Cubase should have such setting as well.

1 Like