addin midi device

I am trying to add an old casio ct5500 with a lexicon u82s, the lexicon has midi in and midi out as does the keyboard although it is an old keyboard.
computer is windows 7 pro, in device manager it shows the lex is working and also the midi from the lex. I am using the lex asio that came with it. everything else works with cuabse all other inputs but I don’t use the spidf .

I don’t get any input signal. I have tried all combinations of inputs and outputs that I can think of in the cubase device manager. I have read the cubase mid stuff , the lex doesn’t come with much, and also midi 101 and other turtorials on this but I am missing something simple I think. any help would be appreciated, I also sent a email to lex support. thanks.

I’m having a hard time understanding what is working and what is not based on your post.

First off - the ASIO driver is for the audio I/O. It has nothing to do with MIDI.

So which input are you not getting? Are you not getting the midi data from the keyboard? You say “everything else works with cuabse all other inputs but I don’t use the spidf .” but you don’t say what doesn’t work other than “I don’t get any input signal”.

So what exactly are you trying to do?
How exactly do you have things set up?

Connect Casio MIDI out to Lexicon MIDI in
Connect Lexicon MIDI out to Casio MIDI in
Power on your devices.
Open Cubase and start a new project.
Within cubase, under device->device setup-> MIDI port setup. Do you see your lexicon device listed and visible?
If so, you should be able to create a MIDI track and assign it’s input to be your lexicon device.
At this point, when you press a key on your Casio, you should see activity on your MIDI channel (bring up the mixer, or look at the project track)


ok I have midi out of keyboard to midi in of lex
in device midi it shows
device i/o port system name shown as visible state in all midi
windows midi [ in [ lexicon io82[ lexicon io82 [x[ active [ x

I don’t get any signal on the midi activity , in the transport or on the midi device on the project

thanks for replying

OK so it seems that Cubase sees your midi device. On your midi track did you set the input routing to your lexicon (or if it’s set to all midi devices that should work too)?

If you did and you still don’t see midi activity on your midi track, the issue could be with the casio (i.e. maybe it’s not sending any midi data out) or a lexicon setup (I know nothing about that interface, but usually there’s nothing to setup). As far as I can see your cubase setup looks OK.

Have you tried this with any other apps? Do you have a different midi keyboard you could test with?



must be something wrong with my midi device.

I would suspect the casio. Maybe a setup issue with the Casio?


ok I guess I need a keyboard,

any suggestions for one that is older (cheaper) I don’t need control from the keyboard I don’t think, 48 keys . thanks for any suggestions

You should really try to verify that the Casio is the problem before you spend money and find out differently.


The keyboard is probably 30 years old, so I don’t mind putting money into a new one. I talked to the lex guy and he confirmed it is hooked up right. Don’t have any other midi device to hook into it. other than a usb which does work.