adding any plugin locks up Cubase pins audio performance meter


I recently upgraded to Cubase 10.5 from 10.

I was able to open the current project I was working on (started in 10) but after adding a couple of plugins, the system beach balled and I had to force quit. I relaunched and tried adding the same plugin and it opened, but then the Audio Performance meter peaked out. All audio stops and main out meters flash intermittently. What’s weird is that I can still navigate Cubase and add inserts, but nothing plays or moves or sends an audio signal. If I quit and relaunch, the project is fine, until I try and add any plugin. Same result with any VST instrument, FX, VST2 or 3, any channel, any manufacturer… it doesn’t work. Cubase is completely unusable.
What’s even more odd, is now this problem has infected my version 10 and it’s now exhibiting the exact same issues so I can’t use that either now.



As I can see, you spread this to several threads here on the forum (1, 2, 3, 4). It’s hard to go thru all of them and make the whole picture out of them, if you leave just a piece of information at every single thread.

Please, make sure your Audio Device driver is up to date. Also make sure you have the very latest Cubase 10.5.20 installed and your plug-ins are up to date, please.

All plugins are up to date and device audio drivers. I posted in response to others posts having similar issues to see if there was a fix. It appears as though there is not, so I decided to start my own thread as my issues seem to be related to others, but not quite the same. I’m new to the forum as I have usually had very few issues with Cubase until v10, but at v10.5.20, my system is now unusable. Please advise.