Adding Shaker to my composition (HALion sonic SE issue)

I have recently purchased the BBCSO Core library, which I am using in my latest composition. However I would also like to use a shaker which isn’t included. I had initially thought it was just a case of assigning a HALion sonic SE VST instrument and choosing shaker from a drop down menu. But it appears it’s a bit more involved than that. I created a separate Dorico file to locate the Shaker sound. HALion Sonic SE under > Drum & Percussion (GM 129) Stereo GM Kit. However when I tried to add a shaker to my main Dorico file it assigned a whistle sound, which appeared to be the next sound along when I clicked on the virtual keyboard. I am not entirely sure why there is this discrepancy, apart from maybe that I had chosen BBCSO and not HALion Sonic SE as my Playback template. I would be most grateful if anyone has any ideas if they could please assist me. Thank you.

After a lot more investigation, I finally found a couple of videos that helped. It seems the shaker hadn’t been automatically assigned a percussion map when it was created. I am not sure why this would be, but under Play I had go to Instruments and click on the cog wheel and then double click on the percussion map and assign Yamaha XG. As mentioned earlier I had already found out I needed to use the HALion sonic se VST (GM 129) Stereo GM Kit. Unfortunately I then had no playback at all, so I then clicked on the e (edit instrument) button to open up the HALion interface and clicked options, bumped up the RAM and performance to 256 from 128 and hey presto success!!! I only wanted to add a shaker, I am musician not a techie, why does Dorico make this process so unintuitive and complicated?

I just wanted to try by myself, since I find your last sentence a little bit biased by this experience and does not express what I feel about Dorico. So, to make an honest test, I started Dorico, new document, add one player : shaker. Boom : it plays shaker. I check whether it’s the same library as yours : it’s not, my default library is NotePerformer. I go to Play mode, Play menu>Playback template>HSSE+HSO apply and close and… boom, my shaker is still there, but this time with the same sound as yours, and the same percussion map.
Ok, what has happened? In my case, I’ve use Dorico the way it’s designed to be used : with as little overrides as possible. You might not know it, but each time you choose stuff on your own in play mode (I mean, change an instrument in a vsti using the vsti editor window), you do override Dorico on its whole playback settings capabilities. Once you’ve chosen “by hand” your shaker, you’ve prevented Dorico from choosing the appropriate percussion map. If you had used the playback template, just as I did, everything would have been working flawlessly.
I’ve taken the time to write this all down so that you know, next time, what workflow will be working, especially if you’re not a techie. Hope it helps!


Hi Marc, Thank you for your response. I don’t think that that I am biased, but I do accept that you have had a different personal experience. I chose to use Dorico’s Spitfire BBCSO Core playback template for my instruments. The problem came when I wanted to add a shaker which used a different playback template. As you said, when you use HALion, Noteperformer or HSSE + HSO things tend to work flawlessly. But I needed to use multiple playback templates in a single composition. As I couldn’t find a way of selecting multiple playback templates I needed to add the Shaker manually. Anyway I have managed to set it up, which is the main thing. I have only been using Dorico for 3 months, having used Sibelius on and off for over 20 years, so I guess this is just another teething problem.

Well, yes, if you already have a playback template loaded and need to change something, it’s totally up to you — unless you want to modify your Spitfire BBCSO template to call for the HSSE shaker if you need it, which is also doable. But this is clearly out of the “mainstream workflow”, and music notation and playback are complex fields, so I’m afraid it’s inevitable that things get more complicated to handle then. Good job that you found out how to do it!