Adjusting Position Of Dual Mono Tracks in a Montage

Hi, folks.

I have a two-channel recording where the left and right and right channel inputs were about 20ms out of phase with each other. I’d like to correct this and then mix the two channels to stereo.

I’ve opened the .wav file in a montage as dual mono, with each channel in a separate track. All good. If I could drag/slide one track 20 ms to the left of the other, it would solve my phasing issue. But I cannot move each track independently. Is there any way to do so?

As a work around, I rendered each mono track to a two-channel .wav file, and I can load both .wav files into a two-track stereo montage, which works as expected in terms of sliding the tracks around. Is there perhaps a better approach?


If you have the left and right channel on their own tracks and you still can’t move them independently, you must have either Ripple Mode and/or Auto Grouping turned on in the Edit Ribbon Tab.

See what happens when you turn them off. See attached.

If that doesn’t do it, it would be helpful to see a screen shot of what you have going on.

Thanks for the quick reply.

Ripple is set to Track and Auto Grouping is turned off. That usually works the way I want it to, with stereo tracks in the montage. Here, changing Ripple to none makes no difference.

I have a feeling that the issue is that there is only a single .wav file, and just like two channels on one track, they are really a single unit and they can’t be non-destructively edited one channel at a time. But I don’t really know for sure.

Interesting. Sorry I wasn’t more clear. It would also be good to see the actual waveform on the montage tracks.

Did you convert the file itself to dual mono or is this a stereo interleaved source?

The file was not interleaved. It’s a plain old PCM .wav file created by playing back a cassette to a digital recorder. I opened the .wav file as dual mono.

The cassette was recorded with separate left and right inputs, one from the soundboard and the other from microphones some distance away. Thus, they are not in sync with each other.

Here’s an image of the waveform, you can see what I mean.

I definitely see what you mean but I was expected a big zoomed out screen shot to see everything. Are you saying that moving one of the clips moves both?

When you make the screen shot, it’d be good to see the Clips Tab exposed.

Yup, both clips move as one. The last pair of clips on the right moved together when I dragged the top one

Interesting. Somehow more info is needed because with the settings and arrangement you see in my screen shot, can move the clip on the bottom track (track 2) without the clip on track 1 moving.

1 Like

Thanks. Good to know that it can be done!

The only thing I see in my montage that’s strange is the negative pre-gap on clips 1 and 2, which which makes no sense. The pre-gap is the length of the clip itself. I wonder if that’s causing math problems…

That is strange. What version of WaveLab 10 are you using? I can’t remember if there was a bug in this area that has been since fixed.

If you make a fresh montage with just one pair of clips like you see in my screen shot, do you get any different results?

Wavelab 10.0.70.

It took a few hours for me to remember how I got into this situation, but I finally figured it out. I don’t really have a dual mono montage because I didn’t create it from two mono clips. Instead, I created a stereo montage, added a stereo clip, and then right clicked under the track name and selected Split Channels > Split into Left / Right mono tracks. That gave me the montage you see above.

I’ll bet the problem is that both mono tracks are, in fact, really the same audio object, and Wavelab can’t move an object relative to itself.

Unless there’s a better explanation, the lesson is that splitting a stereo file into L/R tracks in the Montage doesn’t really create a dual mono montage.

I guess my question boils down to: is there a better or best way to transform a stereo clip into a true dual mono montage with separate tracks for each channel, such that each track is really independent of the other?

Thanks for sticking with me …

No problem. This some good info though, and what I was trying to get at by seeing your clips tab. However, this is uncharted territory for me and I’ve never tried the features you mentioned.

That being said, while it’s not the most elegant way to do this, it seems that if you lock one of the two clips, you can then slide the other one around.

Check my two screen shots, and it’s hard to see but notice the lock icon on the top clip in the one where. they are moved.

1 Like


Yes, locking one clip allows the other to be slid about. Who knew?

It’s a weird one for sure.

In my opinion, splitting the stereo track into mono left/right tracks should have allowed this to work. Maybe there is a better way that @PG1 knows of to do this.

Also, think I noticed a bug for @PG1 to correct.

In your WaveLab 10 screen shot, the two tracks show as mono tracks.

In my WaveLab 11 screen shot, the original track 1 still has the stereo track icon and the bottom one has the mono track icon.

Try copy from original montage and make new montage
with real 2 mono track insert wavs unselect Ripple and Auto Grouping
just test to see if it works to move just one track…

regards S-EH

The point, is that after splitting a track as two mono tracks, WaveLab 10 assumes you want to edit the top and bottom clips in sync. Hence what you observe.
But in WaveLab 11, this has changed, because there is now an explicit option “Siblings” that you can see On/Off, as displayed on Justin’s first picture.

If you often have this edit task, I encourage you updating to WaveLab 11 :wink:

Like S-Ehansson suggested, opening the dual mono file as two individual mono files would immediately give you what you want.

Thanks, everyone. I really appreciate the help!

Picking up on PG1’s comment about wanting to edit the top and bottom clips in sync, it’s ironic that the reason I split the tracks up was to edit them individually! But that said, it’s actually hard to edit both tracks in sync, too. Can I give an example?

In this image, there is a “pop” in the middle of the selected audio on both tracks. On a single-track (two-channel) montage, I could highlight this area, CTRL-X to delete it, and Wavelab would cross-fade the boundaries per my settings. Glitch removed. Or I could change the gain, etc., and that would apply to both channels.

Doing this with precision on two separate tracks is difficult because Wavelab focuses on one clip at a time, and each track holds a different clip. I was able to get what I needed here by:

  1. Using markers to define the boundaries of the removal area and CTRL-PgUp/Down to snap to them.
  2. Splitting to top clip at each boundary
  3. Detaching the markers from the top clip and attaching them to the bottom clip
  4. Snapping to the boundaries and splitting the clip.
  5. Deleting each of the offending areas – but I had to play around with locking one clip b/c I’m using WL 10. I guess that would be easier in WL 11.

I wasn’t able to do this with CTRL-X because deleting audio mid-clip causes the clip boundaries to move, but maybe I could have found a way.

Anyway, maybe this is an unusual situation, I don’t know.

Thanks again to all!

download a demo of WL 11 and test :wink:

regards S-EH

1 Like