Aggregate Time Signatures and Hiding Barlines

Forgive me if this has been covered somewhere already, but I couldn’t find any information for the life of me.

I’m having issues hiding barlines, although I’ve seen people say that it’s very easy. Whenever I toggle/check the options to hide any barlines, it doesn’t actually show up in the score. I was wondering if anybody could tell me what I’m doing wrong, and how to do it correctly.

Also, I’m particularly curious about hiding the dotted barlines that are created by default in aggregate time signatures (5/4 + 1/8 for example). The natural display in such a case would be essentially a measure of 5/4, a dotted barline, and a measure of 1/8. I’d like to be able to hide the dotted barline if I can. Is that possible?

Thanks in advance for any assistance. From what I can tell hiding barlines should be easy, but I can’t seem to make it work.

How are you notating this time sig in your popover?
If you were to fill the measure with eighth-notes (quavers), how would you want them beamed?
(Can you show an image of a measure of this with time sig included?)

I actually haven’t been using the popover for aggregate time signatures, as I found it to produce alternating time sigs instead (although perhaps I’m missing part of the puzzle).

I’ve attached an image of what I have in one measure, and honestly I don’t really care about the beaming. I can tweak that pretty easily. What I’m most concerned with is hiding the dotted barline, or even just hiding barlines in Dorico in general. I can’t seem to make it work, despite using what appears to be the barline hiding option (see other image).

All that said, I did see a hint of how to notate beaming/grouping options in the popover, and I’d certainly appreciate tips on that as well.
Screen Shot 2017-01-16 at 1.57.10 PM.png
Screen Shot 2017-01-16 at 1.52.55 PM.png

Sorry for the double post, but I just realized that I didn’t specify how I would want them beamed. The most important thing is that the final 8th note (the 1/8) would be isolated.

I’m afraid at present you can’t specify that the dashed subdivision between the two time signatures in the aggregate time signature should not draw. I’ve been looking into this today and I believe we will be able to support this via the popover in a future version (though possibly not the next update, 1.0.30). You will be able to type e.g. 5/4|1/8 to get the result you get now, i.e. with the dashed subdivision, but typing e.g. 5/4:1/8, i.e. using a colon as a separator instead of a pipe, will produce an aggregate time signature with no dashed subdivision.

Hello, Daniel!

I decided to “run on” from this thread …

Now, if I hide the time signature in an exercise, intending for the students to enter it, the music shifts to the left, filling the space where the time signature was. How can I fix that?

Also, if I delete the barlines, again intending for the students to add them, the music shrinks. I tried the “hidden barline” option in the properties panel, both in Write mode and Engrave mode, but it didn’t work. The only way seems to be, to “delete” them, but the music shrinks. What am I missing?

Thanx!

This is exciting!

That does make sense since normally you wouldn’t want there to be a space if you’re hiding something. Your use is a bit of a special case. Have you tried selecting the time signature and changing the color to white in engrave mode instead of hiding it? This may get you what you want. I haven’t tried it myself.

Until Dorico 1.1’s horizontal note-moving capabilities arrive, use System Breaks to spread out your music enough that it leaves room for time signatures and bar lines.

(If you consciously leave room for bar lines, aren’t you showing students where to fill them in?)

That does make sense since normally you wouldn’t want there to be a space if you’re hiding something. Your use is a bit of a special case.

Actually, I’ve done this in Sibelius. It’s just, that the “frame based” layout approach in Dorico puts Sibelius in the shade.

I haven’t tried changing the colour of the time signature, but, in another scenario, trying to create empty bars, I changed the colour of a semi-breve, but the portion of the staff line where it sat is broken. I imagine the same would happen with the time signature.

I suspected that might be the case…

You could always add an extra beat to the first measure only, make the first beat a rest, hide both the rest and the time signatures, and then hide the (necessary) time signature in the second measure to “correct” your altered measure. Does that make sense? You’d essentially create one extra beat (or two) and hide those rests to leave the space that way.


I don’t know if that made sense…(I’m very tired at the moment :unamused: ) this is an example: piece is in 4/4. Make measure 1 5/4, first beat a hidden rest, hide the time signature. The rest should still keep the space (I believe). Making measure 1 5/4 would automatically add a 4/4 signature to the second measure. Hide both signatures. Hopefully beat one of measure one will still leave spacing.

I’ll try the system breaks approach and see how it works. Thanx!

Regarding the barlines, no; the piece would have the same spacing as if the barlines were there, but as though I “forgot” to put them in. The students will need to use their knowledge of note values to figure it out.

Some have failed this test before. Ooops! :slight_smile:

BTW- I love the quote in your signature. Great words to live by!

Thanx, man! :laughing:

Is there a way yet to hide the dashed line? Thanks!

Yes, you can use : instead of | in the popover to separate the aggregate time signatures, and that will cause the dashed barlines not to appear.

Awesome! Thank you!

This probably should be updated to reflect the current version…