Akai MPK Mini won't record in Cubase Elements 6

Hello - I’m new here (but well used elsewhere!)

I’ve had Cubase Elements 6 for a while. It came with the Akai MPK Mini (USB) keyboard and I upgraded it to get to Elements 6. However I’ve never managed to get it working properly and gave up - until now when I need it to work.

I’m really a baritone sax player but want to play about with MIDI to create parts for my Ensemble and I can then email everyone a file so that they can learn their parts. So I want to simply record MIDI straight into Cubase. (And I’ll be looking to buy the Akai EWI 5000 just as soon as it’s available and I can get Cubase to work).

However at the moment I can’t get Cubase to record the inputs from the keyboard. I’m operating a Windows 7 Professional 64 bit system on a laptop. I’ve run a different MIDI program (MultiTrack Studio - just the free version) and it works fine in that. I can record and playback without problem. However not with Cubase.

I’ve recorded a MIDI track in MultiTrack Studio and then imported that into Cubase - and that works fine! Just can’t do it directly.

Up until today I couldn’t even see the MPK Mini in the MIDI Port window but it’s there now after I changed the USB port I was using. So I can now see it saying MPK Mini all over the place. I even get MIDI data coming in as I can see from the transport control. But it just doesn’t seem to go anywhere. I’ve tried selecting the keyboard for input and all MIDI for input. I’ve tried using a simple MIDI track and I’ve tried an Instrument track with Halion Sonic SE but nothing. I’ve got monitor and record enable ticked on the tracks and am now at my wits end to understand what I’ve done wrong.

Hopefully it’s just something very simple that I need to do and I’m now issuing this cry for “HELP” in the hope that some kind forum member will save my sanity!

Many thanks in advance


MIDI port is one thing, but did you check MIDI channel? Create a MIDI track, select MPK Mini as input, and then set the MIDI channel to the one tha Akai uses. Should work…

Thanks - I’ll have a look at that later as I don’t have the equipment with me at work. I did have it set to all midi channels so thought that would cover it but I can check them off. Must be something like that as I know there’s a midi signal arriving at Cubase - it shows on the transport.
I’ll report back.


I’ve just used the keyboard with the free midi program and found that the Akai MPK is using track 1.

Then running Cubase with a MIDI track I can see MIDI data arriving from the transport bar. I’ve set it to all inputs, MPK mini and then used either all channels and even tried each channel individually. But none of them work to get the MIDI data to the track.

Unfortunately I don’t have another MIDI device to try it with to see what happens. Anything internal works fine - eg if I create a VST track and bring up Halion Sonic SE editor I can play the virtual keyboard at the bottom and hear the notes. When I select MIDI from the Halion control panel and choose channel 1 (or any other) it isn’t receiving the MIDI data from the external keyboard - yet I can see there is some from the transport.

Seeing as I can use the keyboard with a different program then it can’t be my PC set up and must be something to do with the way Cubase is set but I can’t see what as I’ve covered everything off. Any ideas??



Mmh weird, I’m afraid I’m out of ideas - unless there is some MIDI filtering going on. I never use that myself though, so can’t help you there. One more thing: if you start a brand new project from a template in cubase, is that different?

Hmm the plot thickens.

I’ve had a reply from Akai who told me to follow their install device instructions and import an XML file that they attached. But that’s made no difference at all.

However I’ve then noticed something that might be relevant. If I set up a VST track and open up the HALion Sonic SE editor I can play the virtual keyboard and get sound out. However if I try to record this as a track using the virtual keyboard then I get sound whilst playing but no data gets recorded to the track. I’ve got record enable on and monitor. Just no data to the track so when I rewind and play there’s nothing there.

I don’t know whether that’ll be linked to the problem - but it might be the same problem. Any ideas what might be causing that?


I’m having the same problem with my akai mpk88. Cubase knows it’s there but when I assign it to play any tracks it doesn’t work. I have a Korg Kronos attached too, and it works fine for midi input. I really wish they would fix this. Won’t even consider buying pro until they do.

Had same problem with akaI mini.
Past tense as the mini works well with Cuba’s.
To record press the record button on the transport section as well as on the track.