Akai MPK49 MIDI Issues

Hello,

I recently bought a new Akai MPK49 to integrate with Cubase 7.5.20 to control VST plugin parameters. I am either missing something very fundamental, my Akai is messed up, or Cubase is. I’m really at a loss and have scoured the nets looking for a solution that fits my particular issue. Most people seem to have an issue getting the transport controls on the MPK to work with Cubase, but I got that working no problem. My problem is I can’t seem to get the knobs and faders to properly control the VST plugins via the Quick Controls feature.

So what I do is go to Device -> Device Setup -> VST Quick Controls. Here is where it gets weird. Sometimes the Learn mode works, other times it does not. I can see MIDI input activity on the transport bar, but Cubase Learn doesn’t always pick up the controller info. So I use the MIDI Monitor plugin as a MIDI insert. Sometimes that works, other times it does not. There doesn’t seem to be a pattern between when either one recognizes controller events when the other one does or not. Sometimes they both recognize at the same time, sometimes they don’t. If I change the Presets on the Akai, I can get any variation of this scenario: Learn works, MM doesn’t; Learn doesn’t, MM does; both work; both don’t…

So when the Learn mode does work (regardless if MM does), I set each of my quick control inputs in the VST QC menu to the Akai knobs I turn and hit Apply. I then go to my VST instrument track and go to Quick Controls. Now before I do any assigning, I notice when I turn the knobs, they are already somehow mapped to some of the VSTi’s controls, just not the ones I want them to be mapped to. So I activate Quick Controls and assign the parameters on the VSTi I want to control to each slot, and then none of the knobs do anything at all. They don’t even control the parameters they originally controlled before I assigned anything in the Quick Controls section!

I’m pulling my hair out on this one. So frustrating. I don’t understand what is wrong. I’ve checked the Akai site and their setup instructions say to import an xml file that came with the MPK on a disc and to set the Akai to the Cubase preset. Well my MPK didn’t come with a disc, and apparently that xml file is no longer available on the akai site. In any case, when I set the Akai to the Cubase preset and use Learn mode, it still doesn’t control the plugin parameters, even though I see MIDI data coming in to Cubase.

Any ideas what I am doing wrong, or where I can go to get some help?

PC: Windows 8.1 on Intel i7-3770
DAW: Cubase 7.5.20 64 bit
Interface: Focusrite Saffire Pro 40
Controller: Akai MPK49

Ok, got some help over at the Akai site. I think I am beginning to make sense of what is going on, however I am still seeing some behavior in Cubase that I would not expect, ie MIDI Monitor not seeing controller input, yet the VST plugin on the same track MM is on does; deleted GR mappings all of the sudden working out of the blue…

At any rate, my original issue has been resolved. Check out the discussion here:

http://community.akaipro.com/akai_professional/topics/akai-mpk49-and-cubase-7-midi-issues?rfm=1

I used to have an MPK49. Endless frustration with Cubase (I never got the transport to work, for start…) and the drum pads were unusable (short of a very tricky DIY retrofit, which I never had the courage to attempt.) I ended up selling it and replacing it with a Max49. Absolutely fantastic controller, and the touch faders are even better than Steinberg’s FD units (which I also own.) I now have 24 touch faders online (the Max 49’s 8 channels plus another 16 from 4x FD modules) at any given time (and with the flick of a bank switch I can quickly access up to 96.)

Hey, Indigo, that Max49. Working well then with Cubase? How do you find the keybed on that unit? I have a MPK225 on loan and considering MPK249 or 261 (or Novation SL MKII for that matter . . . ).

Evaluating Cubase Elements 7 and Reaper now to replace my existing recorder. But would like to have control ‘at the keys’. My Tranzport works well with pretty much everything you could toss at it, but still looking at a keyboard controller as well.

Hi, I used an Impulse 49 and I found Automap to be a strength and weakness at the same time. It worked fine with Cubase 7 but as soon as I upgrade to Cubase 8, I had a tough time.

Months later, Novation hasn’t yet updated Automap to support Cubase 8.

I wouldn’t mind if Novation did not advertise Automap being compatible with “Cubase” (they still advertise that), I wouldn’t mind if it took them a month (from release of Cubase 8) to update their software (although I would greatly appreciate it if they were released at the same time), but it’s now been far too long with broken compatibility, to be tolerable. Because of such incompatibility issues, I eventually decided to sell my Impulse 49.