Align dynamics ?

This feature isn’t working here. Regardless of weather dynamics are grouped or linked. Most of my dynamics in this piece have been copied from other staves. Any works of wisdom from other users ?

Align Dynamics is purely cosmetic and only works in Engrave mode. When you say it’s “not working”, what exactly do you mean?

It simply doesn’t do anything, that’s most of the time. In mesures with lots of hairpins and P’s and F’s, most of the time nothing moves, but I can’t seem to find a pattern. I’ve read other threads here talking about lacking functions. Is it working all the time for most people? I’m wondering if it depends on some of my parameters?

At least show us a screenshot, if not a cutdown project. Align Dynamics works reliably for me, but I don’t know what your projects look like.

I’ll send you a pm.

Received and (briefly) looked at, and I completely understand why you’re not posting the file here. I won’t share the file, obviously!
Two things:

  1. In Engraving Options > Dynamics > Vertical Position, the “Minimum Distance below staff for immediate dynamics” should be set exactly half a space higher than the “Minimum Distance below staff for gradual dynamics”. In your project it’s set one quarter of a space higher.
  2. When using Align Dynamics Dorico can’t override existing Offsets in the properties panel. If you’ve already applied offsets your quickest way to remove them is Edit > Reset Position.

Thanks for that ! I’ll try those settings. I’ve been playing with different vertical offsets for dynamics without having yet settled on one yet. The publisher uses hairpins with a very narrow opening, and they don’t seem to naturally align as well as when that setting is wider? In the best of worlds the immediate dynamics would line-up with hairpins not with a baseline, but rather a center point.

Dynamics for me seems to be the slowest part of this program. The whole “group”, “link”, Write mode then Engrave mode is very time consuming.

Why not allow aligning that would automatically un-link the dynamics? Vertical position of dynamics is rarely the same on stave above or below. I’d like to be able to quickly align without worrying about what might happen in other staves. How are people working when on big scores with lots of copied dynamics?

Many thanks!

It’s for this reason that I’ve disabled all linking of dynamics. Sure, I have to sometimes do a little extra work, but I don’t get an unpleasant surprise in some other part of the score.

Hi Dan,

I didn’t even know that was possible ! Still learning lots of things about this program. Think I will be doing the same thing from here on out. By the way, in the "Align dynamics feature working for you ?

Yes, but I typically Group instead.

Clarification: there have been times where Align doesn’t work for me.

Meaning you group before aligning?

Grouping aligns them. For large regions, I select everything in the bars, then I use the following custom key commands:

Ctrl-Shift-F4: filter-select only dynamics
Ctrl-Alt-G: Remove from group (sometimes necessary if the dynamics are already grouped elsewhere)
Ctrl-Shift-G: Group

Grouping will align them but a) that’s not much good if your part layouts have different casting off, and b) (just as with Align Dynamics) it won’t override existing Engrave mode offsets, where you’ve already dragged dynamics around. You need to reset those. This really does work in the project you emailed me, but be careful - I note that you have a heap of hairpins that were entered as an incorrect length, then lengthened in Engrave mode. You’ll need to watch out for those when you Reset Position (or turn off the Engrave mode offsets).

Great info here, many thanks. Yes on the file I sent you (Pianoleo, thanks again for looking at it), I’ve had to extend dynamics horizontally. Someone does my data entry, and the manuscript isn’t very clear and consistent, and editorial mods are needed. I hadn’t grouped or ungrouped when trying to align. I’ll try this on a new score and see if things go better.

All the best !

When I get “incomplete” hairpins, I select the whole range, filter-select dynamics, and re-enter the hairpins.