All Spectral layers processing lost after a tempo detect

Fairly new to spectralayers.

I just spent a bit of time working on a project and removing unwanted sounds and unmixing it. I saved the project and then went back to the arranger track in Cubase and did a tempo detect. That worked fine and I saved the project. I now open the project and the tempo detect info is there as well as spectral layers but none of the speactralayers editing and unmixing is there.

I opened a backup file from before tempo detect and the editing was there. This was before I did any unmixing. Both the editing and mixing are totally gone after tempo detect.

Do you have to do all other Cubase editing before using spectralayers?

Win11 Cubase 12 last release. Newest version of spectral layers including the unreleased fix.

1 Like

Not many people looking at this forum then. Anyone from Steinberg?

Hi mkok,

I can confirm this. Even just inserting one tempo event in a tempo track and the layers disappear.

Repro is easy:

  • Start with an empty project and import an audio file
  • Unmix song
  • Tempo Detection on the audio track
  • A tempo track is created with all the detected tempo events
  • … but all layers disappear :frowning:

Now I make sure to use tempo detection before I do any SL editing/unmixing.

It also happens with C13.

Thanks. It’s not very good but at least I know. I wonder if there is some technical reason for this or if it’s a bug?

So I now started again be did the tempo detect first.

Direct editing works fine but if I then unmix the track Cubase grinds to a halt. It still works but takes ages for anything to happen. I managed to save the project and open it and it was then working fine. If I then try to select and move data from one layer to another it grinds to a halt again. Saving and re-openi fixes it.

I’m a bit disappointed at the moment as I’m trying to get to grips with SL but at every turn it either loses something or brings Cubase to its knees.

Is this a known issue? I’m not getting a crash report as nothing crashes. The cpu doesn’t show high either when this happens

I recently lost hours of work to a Spectralayers bug, after which I could not even open the session (Nuendo would crash). Only way I could open my session was to remove the SL VST3 plug-in. Of course all the SL data was inaccessible.

This is not the first time I’ve encountered serious issues with Spectralayers. Based on my own experience and reading that of others, it’s become obvious that working with SL is just too risky and the program can’t be trusted. Looking for an alternative now…

BTW., I finished the project by exporting the vocal file and re-doing all the edits in the Spectralayers standalone app. Then I imported the edited audio file in as a new Nuendo track. Fun stuff.

I don’t know if it’s a known issue, but I have never experienced what you are describing (like an extreme slow-down resolved by a quit/restart).
I’m also now using GPU acceleration as this is a life-changing improvment in terms of speed.

I agree that there are more issues using ARA mode than the SL10 standalone app. And those issues or crashes are not always easy to reproduce. It is also impossible (for us) to say if it’s due to SL, ARA or Cubase/Nuendo.
I’m using Melodyne a little less these days, but as far as I remember, using Melodyne with ARA is also not as stable as the standalone app.

To me Melodyne in ARA mode with Cubase 12-13 is rock solid - never a crash - whereas SL10, sorry to say, stands on a more shakey ground.
Sometimes it is impossible to ”make extension permanent” when stems have been lifted out to Cubase, or to ”remove extension from audio event” (it will still be activated and opens SL10 when I double click an event to open it in Cubase’ own editor). And sometimes it crashes, seemingly randomly.

And still the Key commands are not sorted out in ARA mode when having SL10 open on a separate screen (e.g. Cmd-z in SL10 with an activated spectral area will perform an ”undo open in extension” in Cubase and close SL10 with edits and all, as will Backspace in a selected area delete the actual - marked - event in Cubase, thus closing SL10 with edits and all, and so on).
Quite frustrating. This is not seen in other ARA extensions (Melodyne, RipX, WaveLab).

In standalone version it is definitely more stable and used as an external editor in WaveLab it is also stable. But not in ARA mode I’m afraid.

I really like SpectraLayers, it is an amazing piece of software and I use it for several hours every day, mostly while remastering old tapes and records I have made.

Just as a point of view…I don’t use Ara “anything” with Cubase13/Nuendo13.

I use, for example, standalone Spectralayers10 to do unmixing, file cleanup etc…export the stems (never actually save a sl project after edits)…and then import the stems individually into whatever Cubendo project.

Same situation if I’m using Melodyne. All in standalone. Never within the daw itself.

Nice & clean.

I’ve looked at ara…why it exists…where it may be useful…and pretty much come up with…ara is never useful for the way I work :slight_smile:

It may be due to my history with slaved tape machines and edit philosophies there. dunno.

Pretty clear by now that ARA is a steaming hot pile of s**t. The sooner Steinberg can lose that dependency, the sooner we can get on with productive use of Spectralayers.

I stupidly expected SL to work perfectly in Cubase with it being Steinberg. I was a bit shocked that it was ARA. The trouble is I would like to stay in Cubase as I can put old recordings into time etc as well but it just won’t play ball. It will be a real pain to swap between standalone and Cubase.

This definitely needs to work seamlessly.

I’m just the opposite mindset . Working standalone Spectralayers (or Wavelab or Melodyne) is THE efficient way to work.

I can demix a 1965 recording standalone, export the stems, clean the stems up, normalize…and once finished…import the stems into an existing Cubase13/Nuendo13 multitrack project, easily adjust time or tempo (if I want)…and proceed onward in the daw.

Everyone has a different way of working. Ara is simply a process that I’ll never have use for.

Now Key Commands work again in ARA mode with Cubase, since 10.0.50!
At last I’m able to do a Cmd-z or Backspace when having SpectraLayers on a separate screen in ARA mode.
Thank you @Robin_Lobel !!!

Edit: Well they worked for 30 minutes but not any more… Wonder why?

Regarding instabilities you may experience in ARA mode, but not in the standalone app, know that both (ARA and standalone) use the exact same binaries. So instabilities you may experience in ARA are more likely due to ARA or the way the host handles it.

Might be but nevertheless frustrating.
And I’m not the only one.

The host (Cubase 12, 13, Nuendo 12) can handle the ARA connections with Melodyne and WaveLab flawlessly when it comes to key commands.

It worked fine some years ago, but then all of the involved apps have been updated to new versions, so I no longer remember whether the change came with SpectraLayers 9 or with Cubase 11 (or 12).

Ok, so I better raise the question at the Cubase departement, or submit a support ticket I suppose.