"Allow rests within beams, maintain secondary beams" option not producing correct results

See attached image. I’m trying to maintain the secondary beams over the demisemiquaver rests. There does not appear to be an option to do this in properties or through the “beam together” shortcut, and the option in Notation Options is not working as advertised.


See original beam grouping in Sibelius, below, for the desired outcome.

I hate to break it to you, but I’m pretty sure this a limitation that was flagged a while back (https://www.steinberg.net/forums/viewtopic.php?t=121297) that hasn’t yet been addressed. I’ve been playing around for the past few minutes and I can’t find a workaround at all. I’d be extremely happy to be corrected on this one.

Your desired appearance is “wrong” as far as Dorico is concerned, because Dorico will only maintain the secondary beams if the note value of the notes and rests are the same either side of the rest.

Ok, so if there ever gets to be a way to change Dorico’s mind about that, it would definitely be appreciated. Dorico’s beliefs are not in line with international best practices, see e.g. 1) Henle, 2) Bärenreiter, 3) Danish Library (Carl Nielsen critical edition), etc



From here:

I know that Notation Options (Cmd-Shift-N Mac)>Beam Grouping>Rests within groups of eighth notes (quavers)

…can be set to beam over rests or to split beams over rests.

I have only one Flow in my project file. When I change the above setting to ‘Break Beams at Rests’ and click ‘Apply’, the appearance of my score and parts do not change, the beams continue to stretch over rests.

What am I doing wrong? :thinking:

Thank you.

Is this an XML imported score? Try Resetting the Beaming (in the Edit > Notations > Beaming menu).

It is an XML import. I’ll try what you suggest. Thanks benwiggy.