always records metronome click

I have adjusted every setting in the metronome setup dialog box (under transport panel) and still the click gets recorded when I try to record audio. I want to hear the click but not record it. I have tried using midi to a vst without the audio checked and still the click is recorded in the audio track. Basically if I can hear the metronome in any way it gets recorded.

I am sure this is a common problem. Any suggestion would be appreciated.


Make sure you have your input buss routed correctly. The problem could be that you have your outputs routed to your inputs, and you’re recording your click to your track.

Thanks for your help. I keep trying but no luck. I tried various options tonight including activating click in the control room but still the same result.

I found the problem. The output from my audio interface went to one of the input channels on my mixer. I just adjust the slider to zero when I want to record audio. Not a problem when recording from a vst. Thanks for your help.

Glad you got it solved!

You may have a function called loopback enabled in your interface. Check the manual for how to disable this. It is intended for podcasts.