Amped Electra e-Licence

Amped Electra has been working fine but now it has deregistered itself!
Cubase (12) warns me that it isn’t available during start up and sure enough, it isn’t.

It still appears in the Library Manager and Halion instruments but there are No Entry signs on the preset list.

I’ve gone on to the Steinberg site and in Sign in I can redeem an access code, but when I send the code to “LCC” I get a Soft e-Licenser File Permission Repair Problem.
This suggests that I start the e-licenser Control Center by right-clicking on its application and selecting “Run as…” I tried doing this as an administrator but it shows , in red, “Deactivated Soft elicenser” in the left-hand column which highlights when I select Ampled Electra fro the column on the right.

I’ve tried selecting the License to upgrade and pasting the redeemed code into this but I just seem to be running around in circles.

I think that I am about of time for getting amped Electra to work. The Steinberg Activation Manager doesn’t work on my PC so I have generally been downloading on my laptop.
I can’t even remember the sequence of procedures that I have gone through to try and get Amped Electra back on the PC. Today I went to my laptop and opened the Activation Manager there. The 2 products listed were Cubase Pro 12 and Amped Electra, both deactivated. I darent touch Cubase to activate it as it’s been running fine. So I activated Amped Electra and it activated. Then I went to my PC, rebooted it and it’s still says Amped Electra’s license is missing! Please help!