Amplitube 5 (and 4) will not detect MIDI from my controller

I’m going mad here - please can someone help! :slight_smile:

I have a Nektar Impact 25+ Midi Controller. It works fine. Cubase (11 Pro) sees it fine and it works with VST instruments fine.

I have an audio track with Amplitube 5 on it as an Insert.

I have set up a separate MIDI track with “All MIDI Inputs” as my input and for the Output, I’ve selected the Audio Track > Amplitube 5 > MIDI Input channel.

For the MIDI output channel I’ve selected “Any”.

Within Amplitube 5 I’ve selected “Any” for the MIDI input channel.

When I press anything on my Nektar keyboard Cubase (and the MIDI channel) detect MIDI messages. Indeed, if I re-route the output of that MIDI channel to a different instrument (e.g. Groove Agent) it detects and plays those MIDI messages.

But when I switch it back to Amplitube, it sends messages, but Amplitube just doesn’t see them.
And it’s driving me mad!!

(as an aside; if I run Amplitube 5 in standalone mode then it detects MIDI no problem)

I just created this 2 minute run though video so you can see exactly what I mean: Screen Recording 2022-03-04...

Any help would be AWESOME!

Thank you :slight_smile:

I have this configuration that works fine. Some part of it may help you.

Audio Track with Guitar in.
FX Track with Apitube
Midi Track with direct out to FX track → MONITOR ENABLED
Group for Guitar Bus
Audio Track to record Apmlitube output

Also Amplitube’s MIDI Learn is a bit of a pain. It isn’t as intuitive as most.

Also, is that Nectar configuration right with MIDI 2 and all? Isn’t that channel for DAW configuration? I don’t know, just a thought.

Thanks a lot for taking the time to share that.

As you say, it’s a bit convoluted, but it works!

I did, however, discover something more bizarre, but easier; if I insert another plugin after Amplitube (in my case, Steinberg’s stock Wah plugin) then Amplitube starts receiving MIDI messages!

It’s like it needed the other plugin to “turn on” MIDI for that Audio track. Odd!

So that the second plugin doesn’t colour the sound, I then “Bypass” it. Amplitube still receives MIDI messages.

But, interestingly, if I “Turn Off” the second plugin (rather than just Bypass) Amplitube stops receiving MIDI!

Which all seems to suggest that there is a bug in the DAW version of Amplitube 5 that doesn’t actually turn on the ability for it to receive MIDI messages.

I’ve also messaged IK Multimedia support, so I’ll see what they say.

Thanks again for your solution - and, maybe, my above workaround might save you a few steps next time you need to implement it :slight_smile:


I had this problem also. I did all the steps the chap first posted but nothing worked. It turned out the solution was pretty simple. As soon as I armed the midi track assigned to amplitude it worked straight away.

hi, i was having this issue which lead me here, i just switched my midi input on the assigned channel from all midi inputs , to the specific keyboard which my expression peddle is plugged into, (Nord electro 4) and it worked for reading the midi right away in amplitube , been driving me mad for ages , hope this helps