Amplitube 5 into Cubase 12, Poor quality Sound (?)

Hello dear friends,
A few months ago i’ve download the free version of AMPLITUBE 5 CS for try it as a recording tool through Cubase 12 Elements
I have made some wonderful sounds in Standalone Mode and saved them as presets. When I use them standalone they are great! But, when I use the exact same presets in the
DAW (Cubase 12 Elements) they sound very harsh and thin, compressed and muddy also i’ve noticed low volume level… standalone sounds are …‘better’
I do NOT get crackles or pops, but It’s like it some kind of compression was applied by default in any preset.
It is the tone that is degraded. I don’t know if the CUBASE itself is doing something to the input, but maybe it’s the reason that the standalone mode sound more open…
Standalone version has some kind of “openess”, clarity and definition that I just can’t achieve in Cubase
I don’t know if it is some configuration in CUBASE that I’m missing.
Clearly something is wrong, but maybe it’s just me who is setting it badly.

Is there some kind of specific settings to use it properly???
Any directions i can find, just simply shows to add Amplitube as an insert and that’s all…

my basic settings are:
sample rate 48 Khz
buffer size 96

adding track config
Insert → Amplitube 5 CS

audio interface: UR22mkII

Any help? Is there anybody with the same question??
Any solution???

Thank you very-very much in advance

Isn’t Amplitude 5 stereo ? if so that could be you lack of openness if by some how you have routed it via a Mono track

yes maybe, but should i deal the instrument (guitar) as a mono signal instument ?
You suggest to set it as stereo input → stereo out?

I would suggest routing your guitar track to a stereo Buss (group) and add Amplitude to the buss

So, i should create a common audio track (configuration–>mono & audio outputs -->stereo)
and then add a group (configuration–>stereo & audio outputs -->stereo) and send the audio track to the stereo group?? i understood it right??
in which of the 2 tracks, Amplitube should insered?? both?
(forgive my irrelevance but i’m an amateur…)

No , you only need to insert amplitude on the Buss track . So you have your guitar track (mono unless you’re using two inputs) and you create a group track, then on the routing you route the Guitar track to the Group track and place the Amplitude on the group track

Yes I see, last clarification, the config of the Buss (group) track? it’s right as the pic below?

Yes that’s right, you can always experiment there’s no harm trying different ways

1 Like

thank very much for your answers
i’m going to check it!

You could also just create a stereo track, route your guitar input to ist and drop Amplitube on that. Is somewhat simpler

1 Like

Still isn’t the same…
surelly it comes much more wide and “open” than before but thinness is still here and lacks of the musicality of the standalone mode.
and of course is an issue that you should create 2 tracks for one playing take…

No, you don’t see my previous post about using AT on a stereo track.
Maybe the standalone version ist just a bit louder and that sounds better to you?
Hard to say what else the problem could be, in general there is no reason why AT should sound different standalone and as a Plugin, the code is the same. Except that there might be of course a bug in their preset loading system, which you could test if you use a packaged preset in both situations.

Your buffer size is 96? Maybe that’s the problem. Does it sound better, when you set much higher bs after recording?

I bought AT5 yesterday and noticed the same difference observed by the OP.
I don’t believe it is an issue related to the length of the driver buffer.
I believe it is something related to mono vs stereo. Let me explain better. I’m still investigating, but what I noticed so far is this: if you put AT5 as an Insert into a STEREO Input Track having only the left channel connected to the actual soundboard input signal, then AT5 produces a lower quality sound than the standalone executable. The reason seems to be that AT5 is working in stereo mode if you put it in a stereo track, though only the left channel is fed by Cubase, decreasing the overall gain according to the pan law and, in general, lowering the quality of the algorithms at work in AT5.

Instead, the standalone executable does replicate the left channel on the right, creating a dual mono input, which feeds AT5 better.
Pay attention to the input levels on the bottom left corner of the AT5 UI and you’ll see that the standalone executable works in dual mono, while in Cubase only one of the two channels is active.
As an additional proof, try to put AT5 as an Insert within a MONO input track: you’ll lose the cool stereo effect in the output, but you’ll hear a higher-gain and higher-quality sound.
If there was a way in Cubase for replicating a mono channel, I mean without introducing additional inserts and workarounds, or if AT5 had a Mono/Stereo version of the plugin, then I believe the two qualities be on par.
Frankly, it is embarrassing that Steinberg (as well as IK Multimedia) have had this very issue for 20 years so far and never managed to solve it in a clean way.

@Alvise_Spano Did you try putting AmpliTube on a Group Channel as FilterFreq suggested above?
Routing a mono channel to a stereo bus (or sending to an FX channel) should supply AT with a dual mono signal.

Yes, I knew that. I’m an old Cubase and Amplitube user :slight_smile: I was just answering to the presumed lower quality thing of the OP, trying to find a reason why the standalone exe sounds better.
Regarding the Group Track trick, it is well known, though I must admit it is unclean as a workaround: tracks proliferate enormously in that way; also, putting AT (or equivalent plugin) in an input track allows for recording of processed sound, as if you had a real amp in a studio. Having AT on a Group Track not only makes you dependent on the configuration of an Insert, but it also has another subtler implication: recording unprocessed sound from a guitar and having the opportunity to change the configuration of AT after the recording, say during mixing, may seem an advantage, but it actually isn’t. Because it gives you too many options, and you end up being unsatisfied and overwhelmed :slight_smile: Just my opinion, ofc, but over the years I started to prefer simple things over tons of possible tweaking :slight_smile:

I haven’t used Amplitube in probably a decade. If I owned it, I’d be interested in performing a simple null test with the stand-alone and VST version. Before that has been done, everything else is speculations in my book.

I’m confused. What do you mean by “the cool stereo effect in the output”? You are using a mono input to feed a stereo track, correct? If so, why would the output not be stereo?

I mean: if you put AT as an Insert into a MONO track, you’ll lose the stereo output, obviously, because the output will be mono. By “cool stereo effect” I just mean the stereo output of AT, which is cooler than a mono output.
By using a mono track, however, you will hear a higher quality of the distortion compared to putting AT on a STEREO track with a NON-dual mono input (e.g. only the left channel). This happens due to the lower gain of a single channel.
To summarize:

AT on a STEREO track:
PRO: stereo output
CON: lower gain due to mono input on a single channel

AT on a MONO track:
PRO: higher gain, thus higher distortion quality
CON: non-stereo output

To get the best from both worlds, you need to put AT on a stereo track with a replicated/dual-mono input. This way AT works as in standalone mode and sounds at full gain.

Ah, I just discovered another trick maybe worth sharing.
Inserting any Mono/Stereo plugin before AT in a stereo track fed by a mono input duplicates the channels and solves the gain/quality problem observed by the OP.
This happens even if you BYPASS the plugin, so it does not matter what plugin you choose as long as it is the Mono/Stereo version of it.
A bypassed plugin allocates a marginal amount of CPU, you won’t notice the difference in CPU load.
One last word: for “bypass” I mean the “Bypass Effect” button in the top left corner of the plugin window, just on the right of the “Activate Effect” button.