An Amateur Guide To Connecting And Using the Moxf8 in your Daw

Hello everyone,
I decided to post this because from my drilling through the topics here, I’m of the opinion this is a serious issue with most users of the Moxf8. I’ve owned the MOXF8 since October, 2017 (I bought it in Sheffield, UK while visiting), but never got it to work with cubase. Another guy who posted on this forum has had it for 4 years and never got it to work with Cubase. The Moxf8 editor manual, and the user manual appear to be very complex for the amateur in some way. Someone needs to decongest and translate this process through very simple steps and that’s what am doing below:

FIRST METHOD OF CONNECTING THE MOXF TO YOUR DAW
(1) Things to get handy: A USB to Midi cable, download the Steinberg USB Driver (you may not use this ultimately but i will explain later), download moxf editor, and the remote tools too.
(2) Connect the USB cable to your computer and your mox after downloading and installing the drivers and the editor.
(3) Set parameters like Local control to off from the utility function, also set function to USB (pressing Quick set up will do all the settings for you and the remote tools you installed will also do the settings at the Cubase/DAW end. But that’s not where it ends.
(4) Now concerning your audio driver and soundcard (if you want to use the MOXF as your soundcard, then you can select Steinberg USB ASIO Driver as your audio interface in the studio set up menu. However, if you want to use another audio interface (I use Focusrite) then select that driver. In Cubase go to studio-set up, select your audio interface as the main driver, make sure port 1 and 2 are checked. In your Midi Ports tick the driver you use eg. Focusrite Midi. Ensure that one is checked.
(5) Click on Audio Connections/Device Manager (depending on what version of Cubase you use). Create Stereo inputs and assign ports 1 and 2, then flip to outputs and create stereo outputs and assign it to 1 and 2.
(6) Launch MOXF Editor. Allow it to synchronize with your Yamaha MOX instrument. Once it’s done, the status would show ONLINE. Click on the Set up and check the panel for settings. Uncheck USB. Ensure your device is set to 1. When you uncheck the USB dialog box, it will grey out. Don’t touch the settings. They are done automatically by remote tools. If you have already messed around with these parameters, please go to page 7 of the MOX Editor Manua. Ensure USB Device shows MOX6/MOXF8. Uncheck VOICES so it greys out.
(7) Go to VSTi Settings panel and check the routing. The top two routing should show Ports 3 and 4 respectively. Leave the two bottom parts unchecked/unassigned. This one is critical if you are to get audio from the Midi recordings.
(8) Go to your project window. From the instrument rack select MOX/MOXF 8. It will create/load onto your project window. Select the track it loads and go to project inspector. Select inputs to ALL MIDI INPUTS and then select output to MOX6/MOXF8 MIDI IN (This is the key to a whole lot. You may record, play back but if you don’t set these two as above, you wont be able to export your midi to audio.
(9) Record on the track. Play back and you would see the tiny spot on the MOXF8 rack on the right panel glistening while you playback. That green light shows audio is routed through it. If it doesn’t light and indicate, you would struggle to export to audio.
(10) One final cautionary word. While using/setting up the MOX6/MOXF8 with the MOX Editor, leave the external instruments panel on the audio connections settings alone. Don’t assign any ports there to anything eg the MOXF8. If you do, you are doubling or duplicating the routing. The MOX Editor would punish you by scrambling other settings and you would keep going back and forth resetting things. Very stressing indeed. This gave me hell for 3 good years. No online tutorial or comments helped me solve this.
(11) You can load as many as 16 tracks on the editor and record them as midi. If you want to open a second instance of the MOX Editor, first freeze your tracks using the freeze function on the MOXF INSTRUMENT rack. Otherwise, the Editor will have port assignment issues.

SECOND WAY OF CONNECTING THE MOXF8 TO YOUR DAW
Before I finally resolved my MOX EDITOR dilemma, I settled for this one. Greg Ondo taught me how to use this method (https://www.youtube.com/watch?v=d_S63n3V71Y ). It works and its as good as using the editor, but the only thing is you have to assign your voice parameters on the MOXF8 directly MOST of the time and not in your DAW.

  1. Connect your MOXF to your computer using the USBD cable
  2. No need to download Editor or Remote tools or anything.
  3. In Cubase select Studio-Audio Devices-Add Devices and set up the MOXF as a new device.
  4. Go to Audio Connections–External Instruments–Set up the MOXF as an external instrument
  5. You are set to go. Please watch Greg Ondo’s video on this (link above) and its easy. I won’t repeat it so much here.

Load the MOXF from the instrument rack, creating a track. Then right click and add as many midi tracks as you want. Notice they are numbered from 1 to end. Go to your MOXF and select SONG. press Mixer/MIXING. Assign voice notes to tracks on the mixing panel. Each track you select on the mixer will now correspond with tracks in CUBASE. When you select any track on CUBASE, press your keyboard and the notes/voice would correspond. It’s simple. So you record onto each track. If you choose to have only one MIDI track, set the channel as ANY in the Cubase track. In this way, you should be able to record all the tracks on your MOXF8 onto one midi track. There’s no limit to number of tracks you can record (better than MOXF EDITOR approach). After recording as many tracks as possible on the one MIDI track, select SHOW LANES. All your individual/separate tracks would unfold below the main track. You can edit and export them to audio separate by clicking SOLO on each of the tracks to mute the rest during mixdown. I have gotten used to this method and love it cos of the flexibility and it makes me work harder understanding my MOXF8 cos i have to do all my voice selection, effect sends, on the MOXF8 itself before i start recording.

That’s it guys. I hope i wasn’t much of a bore. The LOCKDOWN is helping me figure out a whole lot and am grateful. I just upgraded to Cubase 10.5 and please can you help me figure out why it’s blocking off all my Waves Plugins? I also use my Cubase 9.5 as well (ave gotten used to it) and 9.5 is fine and recognizes my waves plugins. So i now end up mixing in 9.5 while producing my tracks in 10.5. It’s a bit of a stretch and ave tried all fixes and nothing works. I hope I wont have to wait another 3 years like the MOXF8 to get a solution.

Thanks and please keep safe.

Thanks! I’ve been wrestling with this for a few days. I’ll report back as to how I do.

I just wanted to thank you for this post. Mid July this year I started trying to make the MoxF8 connect with Cubase Pro 10 and a UR44. As you said the manuals really are not helpful. I too read and tried out some of the many responses my Bad Mister but there was always something missing. At first I was not able to get your option 1 working by after watching the Greg Ondo video and some adjustments - that worked and somehow a few days later I have option 1 working. Key points for me was choosing Instrument RACK vs Instrument track. You’d think they’d rename it or at least throw up a warning. Then finding exactly where in the MOXF editor where you set up the outputs. Once I found that it all came together. So again - thank you!!