An awful lot of msgs with problems, and few with praise for CB12. What is the real status?

You always get loads of post when a new version is released. Just look at how many Dorico post when that moved to the new licensing system.

Flawless install and first impressions pretty stable for a .0 release . Will check all functions tomorrow

Solid here

Too busy having fun playing with it. No disaster’s or end of the world here.

I’m having so many problems with C12 that I’m going back to C11. No crashes, just lots of stupid stuff that doesn’t work now. I’ve entered questions on this forum about a couple of them. Meanwhile, I’ve got work to do… :frowning:

1 Like

No problems here.

No problems here either. It seems a little bit smoother on Windows 10

I had been using Bitwig for a bit after being unhappy with performance on my Mac and admittedly being interested in the modularity of Bitwig. Tried Logic for a bit and never really got into it after having started production on Cubase. The performance improvements, Apple Silicon support, new audio warp capabilities, moves to remove the dongle (I like mobility), and MIDI remote support got me hyped so I decided to pull the trigger.

I’m really noticing the performance improvements and am excited to get some time later in the week to dig into the new features more. So far the experience as been great running under Rosetta. I really missed Cubase :sweat_smile:

I’m not having any issues I didn’t have in 11. The new piano is pretty awesome. I’m just hoping they don’t mess with the quick controls because I use them a lot for automation and programs like Helix native.

on win10 everything perfect, I worked on it the last two days intensively. no crashes, no problems, all very stable and much smoother … CPU usage handled much better than C11 … a big step forward.

Smooth installation. Works great.

After reading the forumissues with the upgrade to C12 Elements (from C11 EE) I was a bit reluctant to upgrade, but luckely there were successtories too, so I did it. So far everything work fine for me too, I’m happy to say. I do keep my other cubase version installed also for the time being.

By the way, there was a slight hick up. Prologue couldn’t be found after the update to C12 Elements from C11 EE, so I just copied the corresponding ‘SynthEngine LE AI Ellements.vst3’ from within C11 ‘VST3’-map to the corresponding file in C12 and it was detected again. 'Bit strange, but it works again. A little bug?

Not a bug: Prologue (and Mystic, Specter, LoopMash) are not longer included in the factory content of Cubase due to technical reasons:

I was afraid to update, with so much bad news, but I have updated from C10 and with Win 11. At the moment everything works correctly.

Upgrade went fine - no issues. Windows 10 here. I sill have 11 installed but old projects opened up just fine in 12.

Right. Thanks for the info

I had problems loading 12 after updating from 11 with video initilization errors… followed loads of work arounds that didnt work. Ultimatley i had to update my nvidia driver to latest and delete the cubase _12 64 folder and move my cubase_11 64 to a temp location, and let cubase reset its self. Once it had loaded ok and closed down i was then able to move my cubase_11 64 back to the original location…c:/ Users (name)/ appdata/roaming/steinberg.
You need to unhide all folders in folder options to see the appdata folder.

Great new additions, especially on the midi device side of things, was hoping for a loop/phrase/building block addition a bit like the dreaded abelton live, just for quick idea buidling when inspiration fails me. but no joy. May be a feature in the future. It would draw a lot more users to cubase i feel. Looks like my akai force will be playing the part for the time being.

Upgrading was a little tricky.

But once installed, its been working smoothly for the last 3 days… Also, running 11Pro alongside with no problem.

Well done Steinberg!

1 Like

Some older bugs not fixed yet but this update ist great and working, except sometimes KompleteKontrol instances are not found and QC didn‘t show (but working) on some VSTs like Massive X or Spectrasonics instruments…
On my Intel Mac the Download Manager starts with an error, activation works after starting the ActivationManager.