An Error Occurred - Dorico 1.2 - Slurs (Bug?)

Hi,

I am trying to copy a work from public domain in order to learn working with Dorico.
When making Slurs and adjusting them via mouse over several Notes, I get the message: An Error Occurred.

This also happened in another project of mine (New Projects work without Slurs Error messages).
Maybe the project files have become corrupt after a while ?

Is this reproducible on other systems ?

I have attached the problematic zip here https://we.tl/xEddyUV35H

Following things to consider when trying to reproduce:

  1. Edit - Preferences - Allow multiple items to be created with the mouse (Enabled)
  2. press S (no selection)
  3. try to drag the mouse over some notes (Error…)

Thanks, lokotus
Corrupt Message Slurs.PNG

Dear lokotus,
If you really want to learn working with Dorico, I suggest you try and use the mouse as little as possible. There are many things that can be quickly achieved with the keyboard, and Dorico’s workflow is optimized for the keyboard (much more efficient than mouse for the time being).
About the problem you’re having : I own Dorico since october 2016 19th and I do not remember having seen such a message. Sorry!

Thanks for the tip. A while a go the new option: “Edit - Preferences - Allow multiple items to be created with the mouse (Enabled)”
was introduced and enables the user to quickly drag slurs only via mouse. The problem is this weird error message, which is reproducible on my system even after restart…
That option is the fastest way to draw slurs with 1 click … if it works …

Hi replying with my phone at the moment and not in front of Dorico. All you have to do is select the notes you want slurred with the marquee or any other selection technique, and type s. I believe you are confusing the terminology about multiple items. That terminology refers to for instance select a dynamic marking and click in that same dynamic markings as many times as you want without having to reselect the dynamic from the toolbox. This option is not required to slur multiple notes.

That is right - I am confusing this - The option is not really necessary for the workflow, thanks
Nevertheless, in this official youtube tutorial at 3min17: https://youtu.be/JjIyO2cQyQw?t=3m17s
the instructor turns on the option and afterwards simply drags slurs with the mouse (no marquee or extra selection required), which I find pretty fast and useful. But this exact workflow causes the reproducable error message in the provided dorico file.

Cheers, lokotus

Lokotus,

I’m back in front of Dorico now, and I can confirm that I get the error too with this file. Other files work fine for me. The only way to not get the error is to first place the slur by selecting a single note and pressing s (which gives a slur spanning two notes), then I can select the end of the slur and extend by dragging. Simply clicking on a note and extending as in the video gives the error dialog. There must be something going on with this particular file, because I never get this error on other files using any of the techniques discussed - it simply works like a charm. Hopefully someone from the dev. team can figure this one out.

Thanks for checking it out. Maybe some developer can look into it too. I am actually getting this error also on another project. I start the project with my template and everything works fine. The error appears after a while (and remains to be a problem even after restart), probably after using a certain combination of keystrokes I have not figured out yet… Something must be saved in that file that causes the error message …

Cheers, lokotus

Marc, if you get a chance, could you try using the example file from lokotus? I tried it and see the error dialog.

https://we.tl/xEddyUV35H

Dear Musicmaven,
I trust you and lokutus, there’s really nothing more I can do… Let’s wait for the Dorico people who will tell us what’s going on :wink:

error again with another Project concerning this slur behaviour an newest D Pro 2 Update. Seems like a nasty bug…

I’m very happy to look at this, but the WeTransfer file has now expired (or has been deleted since it’s already been downloaded). Re-upload and I’ll test it out.

Here we go. This is a D 1 Project. But as I said, it also happened on another project of mine in Dorico 2.
I used Dorico on Win. Have opened the Bug Score again on Mac again (same error)

https://we.tl/OOkRWjQQgN

Cheers, lokotus

Your project opens on my machine with TWO windows open. If I have both windows open, I get the “An error occurred” message. If I close one of the two windows, the problem goes away.

I can replicate this in other projects, reliably, in Dorico 2. I’ve not bothered to try it in Dorico 1.2.

Hopefully the team will note this as a bug, and fix it, and in the meantime you have a workaround: shut that second window.

good point, thanks for clarifying a possible cause. Please Fix Steinberg.

Thanks for pinning this down. We will try to take care of this problem as soon as possible.