An issue re: Concert vs. Transposed Pitch on printout

I was just wondering: is it me or is there a serious risk of error when printing parts that one has forgotten to make “transposed” vs. “concert”? Especially when doing things using an “atonal” clef (as is customary for film even for pieces with a clearer implied key, etc., needless to say), there isn’t even a visual reminder that you are, in fact, “transposed” based on seeing the key signature change, etc. (I THOUGHT that if I went to Layout Options, selected all the parts, and then choose Players->“Transposing Layout” that this would ensure the Parts defaulted to their Transposed versions. However, this isn’t apparently the case).

My question: is there some foolproof way (without tediously checking Edit–>Concert vs. Transposed before printing for each and every Part) to double-check that I AM, in fact, seeing Transposed Parts?

I should add: I also tried creating a Key Command that I would automatically hit just before printing a part to be safe. However, the only two assignable options are “Change Layout Transposition” and “Toggle Layout Transposition”, when what I’d REALLY want is simply a key command that would definitively make the Part a “Transposed Part” (regardless of what it’s current state is), rather than toggling it (which would require that I already know whether it’s Concert or Transposed and defeat the purpose of the key command).

At the least, it would be very helpful (perhaps in the future) if there was an option to definitively make sure the printout was Transposed, or to at least show some sort of different color or border or something - or even a Signpost you can see when doing final tweaks in Engrave Mode that says “Transposed Part”, so you know what you’re looking at before printing (or another option: perhaps adding something to the Layouts listed at the left when in Print Mode - - even a different color for the part you’re printing, etc., depending upon whether it’s transposed or Concert) - though I definitely defer to you in terms of what to actually do…

  • D.D.

Dear D.D,
My advice is that you choose Edit menu>Transposed pitch before the print task, this is the version you will output. I would not use the toggle keyboard shortcut for this.

You can assign a key command to force something to be in transposed pitch: assign a shortcut to Edit > Change Layout Transposition > Transposing Score.

Ah, so there IS a way to assign a key command - this will definitely help. However, I still maintain (for what it’s worth) that there should be a much more obvious way to triple-check that you are actually looking at a Transposed Part (vs. Concert) - I’ve already given at least 1 Bb tenor chart to someone (the first time I used Dorico, admittedly :slight_smile:) that was NOT transposed and he learned the entire thing in the wrong key (!) Obviously my bad, but I still admittedly like that Sibelius had a blatant indicator in the (otherwise “dreaded” by many) Ribbon, etc…

I’m also wondering: isn’t there a way to set things so that the Parts by default are ALWAYS displaying transposed, and the Score (should I desire this) is ALWAYS displayed Concert (unless I manually change it otherwise?) I couldn’t figure out how to do this, if so…

Thanks as always -

  • D.D.

If you set this correctly, and then don’t touch the option in the Edit menu, you should be safe.

You can of course also check that all your parts are transposed by opening the Players page of Layout Options, as Leo shows, and then click the button in the bottom left corner of the dialog to select all part layouts: provided the ‘Transposed layout’ checkbox is still checked when all parts are selected, then all parts are transposed. And if it isn’t, you can simply check it, and then click Apply.

I understand where robjohn is coming from. My first couple of times printing, parts printed in concert pitch. While I understand the options and all of the places to check or select transposed parts, it does seem counterintuitive to me. When printing a transposed instrument, irrespective of how you’re working with it in the score, it would make sense to default to printing a transposed part.

I’m sure there’s Dorico logic behind this, most likely how we’re dealing with “players” and not “instruments,” and the concept of multiple layouts. It just takes some getting used to.

Jim

Jim, all part layouts are displayed transposed pitch by default. Dorico will only print them in concert pitch if you’ve explicitly set them to be displayed in concert pitch.

Hmm . . . Daniel, that’s very odd. (Not the default - that’s perfectly logical!) But that wasn’t my experience.

However, it was a while ago, and there’s a very real possibility that I created parts based on a full score template, or some such nonsense.

Anyway, good to know! Thanks!

When I use a template e.g. Orchestra then the parts of the transposing instruments are not set to be displayed transposed by default.
And when I create a new file with transposing instruments and even if I switch to transposing display in full score via shortcut it stays untransposed in the part and it is not set in the players menu by default to transpose layout.
So when are the part layouts displayed transposed pitch by default?

Thanks.

When I use a template e.g. Orchestra the parts of all instruments are set to be displayed transposed by default.

If you’ve overridden the defaults in Layout Options, that’s your fault, not Dorico’s. In Layout Options, you can always reset to factory defaults by holding the Alt/Option key on your keyboard. The “Reset to Saved Defaults” button will magically become a “Reset to Factory” button.

edit: you can also correct this one thing to the default by doing the following:
Go into Layout Options
Select any part layout
Set the Layout Type dropdown in the bottom left corner to “part” (if it isn’t)
Reset to saved defaults
Tick the Transposed Layout Option
Click Apply
Click Save As Default

Take this as a reminder that a) you can change the defaults and b) they matter! Both in the project you’re working on this minute and the ones you work on after dinner/next month/next year.

What you’re saying makes sense. However, I just opened a blank “film orchestra” template, opened up Layout Options, and looked at the default settings for an instrument I’m sure I’ve never used (“Side Drum”). I also created a new player that typically one would expect to be transposed in the Parts, that I’d also previously never used or saved (Contra Alto Clarinet (E Flat)). In both cases (and, in fact, in ALL my instruments), the “Layout Type” you describe has NEVER defaulted to a Part Layout, but rather always defaults to “Full Score”, and “Transposing layout” has (as far as I recall) NEVER been selected by default, at least when I create a score from scratch, instrument by instrument, as I’ve been doing (though I will try to set this manually now). Having said that, I definitely did NOT know you could hold option and “Reset to Factory” and when I do that, you are correct that “Tranposing layout” is selected by default. All of this to say: I’m confused why these settings somehow were not defaulting to Part Layouts and “Transposing Layout” in the first place.

Even if this solves the immediate problem, just the fact that there can be any ambiguity (even possibly due to one’s own human error at some point) makes me still feel like it would be extremely helpful just before printing to have a stronger visual indication/confirmation that you are indeed looking at a Transposed Part (just my two cents). Otherwise, I will most likely paranoidly waste a great deal of time checking this for every part before printout as it would be the most embarrassing sign of professional “lameness” to give someone a non-transposed part by mistake, etc. (needless to say!)…

Also: when (in Layout Options) I open a Dorico orchestral template and select all the parts, there doesn’t seem to be a way to hit option and choose “Reset to Factory” to all of them at once and am not sure why?

Finally: as a test I started a new Dorico project and added an “Oboe” to it. In the Layout Options I then changed the Layout Type (which defaults to Full score - not part) to “Part”, and then option-clicked so I could choose “Reset to Factory”, followed by “Save as Default”.

Why, then, when I close Dorico and then open a new Dorico session and create an “Oboe” once more, does it default to the Full Score “Layout type”? Didn’t I just tell it to default to “Part”? This is why I’m admittedly confused - but any additional clarification on any of the above would be most welcome as always.

Best and thanks -

  • D.D.

The default is not for the individual instrument, it’s for each type of layout. There’s one set of defaults for Parts and another for Scores. Whether you’ve edited a Side Drum or a Contra Alto Clarinet is entirely irrelevant.

Also: when (in Layout Options) I open a Dorico orchestral template and select all the parts, there doesn’t seem to be a way to hit option and choose “Reset to Factory” to all of them at once and am not sure why?

The thing about defaulting to a Score Layout is a misunderstanding. The toolbar at the bottom of Layout Options defaults to controlling Full Score Layouts, but that’s separate from the selected layouts above it until you need to actually use the Save As Default / Restore Factory buttons. At that point you need to ensure that the layout type there matches the layout type of the layout(s) selected above, or the buttons won’t be available to you. This also explains why it’s seemingly impossible to select a whole load of parts at once and restore them all to factory defaults in one go.

Finally: as a test I started a new Dorico project and added an “Oboe” to it. In the Layout Options I then changed the Layout Type (which defaults to Full score - not part) to “Part”, and then option-clicked so I could choose “Reset to Factory”, followed by “Save as Default”.

Why, then, when I close Dorico and then open a new Dorico session and create an “Oboe” once more, does it default to the Full Score “Layout type”? Didn’t I just tell it to default to “Part”? This is why I’m admittedly confused - but any additional clarification on any of the above would be most welcome as always.

See above. It’s the dropdown that’s defaulting to Full Score, NOT the actual selected layout.

This might help you to understand the concept a bit more easily: https://steinberg.help/dorico/v1/en/dorico/topics/setup_mode/setup_mode_layout_options_r.html?hl=layout%2Coptions

Still wrapping my head around it but thanks all for the help. The bottom line is that there is a way to have the parts default to Transposed, which was ultimately my main goal. However, I have to say that some of the implementation in Layout Options (the Score vs. Part selector in the lower left, and what it applies to) strikes me as confusing (but perhaps that’s just me?)…I still also wish there was even more of a reminder visually when printing that what you’re dealing with is actually a Transposed Part (since it’s so easy to accidentally change it in the Edit menu or by accidentally changing the default behavior, etc.) and it’s such a huge issue to give someone the wrong transposition in a professional situation, etc. For example, I’d love to be able to not only hit a key command (as Daniel suggested) to convert the currently selected part to Transposed (if it isn’t already), but to also have some sort of on-screen “Transposed” indicator show up to be tripley sure (so I don’t have to keep checking the Edit menu for the “Tranposed” checkmark - but again, maybe this doesn’t bother anyone else?)…
Best -

  • D.D.

Dear D.D.,
I was thinking, reading your last post… There’s no need for a non-transposed part, when dealing with transposing instrument. Maybe there could be a warning when the user is about to just do that, export or print something unusual. Only to make sure it’s what the user really wants. This would keep the normal workflow uncluttered with warnings or useless markings. Just thinking out loud here…

Yes - a polite warning WOULD be nice before otherwise potentially printing a part accidentally in concert (which we’d have the option of disabling in preferences if one preferred, etc.)…I just think it’s wierd that it IS quite possible to accidentally set this wrong for a single part (with no confirmation system) and it only takes 1 such screw up to cause problems on an orchestral writing gig…

  • D.D.

Re: Marc’s point about non-transposing parts not being necessary: there are fringe cases where the flexibility is useful.

For example, you have a big piece for singers and orchestral forces. Your page size for scores is way bigger than your page size for parts, and you want to prepare some sort of layout for the singers in which various other instruments appear (for them to pitch notes or whatever, so entirely separate staves, not traditional cues). In this instance a new part layout makes more sense than a new score layout, and you’d want a non-transposed layout.

But yes, I agree that some sort of warning would be helpful. Hopefully someone from the team will pick up on this thread.

Another suggestion (yes, the dreaded “telling the programmers how to design the program”, which I realize is definitely not my territory!): what about just a Signpost you could hide that says “Transposed Pitch”? That way it could be easily hidden, or I could keep it on as extra triple-check sort of visual when doing final Engrave Mode tweaks, before printing everything en masse in Print Mode?

  • D.D.

Last weekend I did some work on the start of an informational read-out on the status bar at the bottom left-hand corner of the window. One of the three things it currently contains is a read-out of whether the current layout is in concert or transposed pitch. However:

  1. Part layouts are in transposed pitch by default. We don’t have a default shortcut to change the layout transposition. It is practically impossible to accidentally change a layout from transposed to concert pitch.

  2. The best way to check whether or not all your part layouts are in transposed pitch takes just a couple of moments: Command-Shift-L to open the Layout Options dialog, click the button to select the part layouts, look at the ‘Transposing layout’ checkbox at the top of the Players page.

I feel as if this thread has been beaten into the ground. Can we put it to bed now?

Yes - and looking forward to that informational readout! I DID manage to somehow change parts to concert and have no idea how, but I’ve got it sorted now so won’t worry about it. Thanks again -
D.D.