Another borked activation thread

A while back, I upgraded Cubase Pro 8 to Pro 10 on my computer, and upgraded the license in the USB dongle using eLicenser.

Now I have a new computer. I downloaded and installed Cubase Pro 10.5. When I run, I’m given a dialog box saying I haven’t permanently activated my license.

If I click the “Start License Activation” button, I get this dialog from eLicenser, asking me to enter an activation code.

If I dig up the license code I got in email when I upgraded and enter it (I already did this before, btw) it asks me for a valid license to upgrade. It shows … no licenses to upgrade.
That’s not surprising, given that I already have upgraded the license, as can be seen in this dialog:

OK, so maybe there’s some “maintenance task” needed? I run the eLicenser Control Center (version 6.11.10.2264, downloaded recently) and get a dialog saying it wants to sync with online. I let it.

It claims to succeed:

And I can see the license on the USB stick:

So, what’s going wrong here?

This computer runs Windows 10 Pro, Threadripper 1950x, 64 GB of RAM, GeForce 1080Ti graphics card, 1 TB M.1 system drive and 1 TB Sata SSD media drive and 1 TB M.1 drive for a separate Linux install. I have the latest version of the AMI UEFI firmware (version 1203) for the motherboard (Asus PRIME X399-A) with a few USB devices installed (Steinberg UR22 interface, Korg MicroKey, keyboard, mouse, webcam, etc.)

I filed a support ticket with Steinberg 2 weeks ago, and got an email saying they would take longer to get back to me, but that was two weeks ago, and I’m runing low on available hours still on the license key.


(The forum complains that images can only be 700 pixels wide. These are literally screen shots from the dialogs … why is this even a thing? I’ll re-format them.)

FWIW, when I log into My Steinberg, I also see the license for Cubase Pro 10. The USB-eLicenser serial number listed there seems to be the same as the one listed in the Control Center software.



You have a license for 10. You are trying to use 10.5. If you want to use 10.5, purchase the update.

https://new.steinberg.net/cubase/?_sp=cf9d869e-8535-44de-912e-fb1c82fbc185.1588172268928&buy=47673&_ga=2.57296170.120565675.1588172262-261323704.1588172262

OK, that was not obvious. I even googled “is there a cost to upgrade cubase from 10.0 to 10.5?” and found nothing. I looked for an upgrade in the store, and didn’t find one.

Also, look at this dialog:

Where does it say that I don’t have a Cubase 10.5 licese? It’s asking for a Cubase 10 license, and telling me the Cubase 10 license isn’t activated.

Something doesn’t seem quite right there. Are you launching Cubase 10 or 10.5 when you get this message? You certainly seem to have a legit Cubase 10 license.