Any ideas why Dorico 4 Pro keeps freezing on me?

I am having issues with Dorico 4 Pro freezing on me at the moment. It happens every few minutes but randomly and tends to last 10 to 20 seconds, though sometimes it lasts longer and I am forced to kill the whole process in Task Manager.
Obviously, it’s really frustrating as my workflow is being interrupted constantly. The file I am working on at the moment has an 8-part choir and organ and I am playing back with Olympus Elements and Halion through a UR22mkII on Windows 11, Core i7 10700 2.9GHz 16GB RAM.
Any suggestions for possible things to try would be greatly appreciated.

Welcome to the forum @DorsetJohn. I’m guessing one of the first things a Steinberg team member will tell you to do is to create and upload a Diagnostics Report once you reopen Dorico after a crash.

Help > Create Diagnostic Report, which writes a file on your desktop.

Have you tried fooling around with other projects for a few minutes? ie to find out if it might be just one project?

1 Like

Of course. It’s just happened again so I’ve made a DR but it is apparently too large for me to upload to this forum (?).
Yes, I’ve tried multiple projects and the issue is not limited to a particular file or even scoring. It’s happening with solo classical guitar pieces as well as bigger orchestral/choral scores.

Daniel or one of the other Team members will doubtless contact you soon and ask you to email them the Diagnostic Report.
I hope you get a response soon, and again, welcome to the forum.

Yes; diagnostic report and any files that are particularly problematic will be necessary.

You can email the diagnostic report to me at d dot spreadbury at steinberg dot de.

Done -thank you for reaching out. I’ll be interested to see what the report reveals.

It looks to me like the periodic freezing is being caused by auto-save. By default Dorico will auto-save every five minutes, and it looks as if auto-save is routinely taking more than 10 seconds (and sometimes a lot more) on your system.

I can’t see any obvious reason for that. You might try saving your projects on your local drive rather than in OneDrive to see if that helps. You could also try switching off the option Generate preview thumbnails when saving in File > Project Info, though from the logs it doesn’t appear that your projects are so large that generating the thumbnails is taking too much time.

Another option would be to switch off auto-save altogether (on the Files page of Preferences) and then save manually, but saving and auto-saving should take the same amount of time, so you may well still encounter a delay at that point.

1 Like

Thanks, Daniel. I will experiment with those suggestions and report back.

1 Like

I’ve not made much progress, but mostly through lack of time.
Anyway, I wonder if @dspreadbury (or any other kind soul) can point me towards the right bit of the Diagnostic Report to check the file saving times to which Daniel refers? I can then see how various hardware tweaks affect it.

The application.log file (which will be in the same folder as your user preferences, scripts, Play templates, etc) will show a time value for nearly every operation.

Thank you!